Dear Tetsuo and Yves
@Tetsuo thanks for this interface functions. I would like to use this opportunity to discuss about the word "brick" in the naming of our functions adding PDE term matrices. Traditionally, "brick" was only used at the end of the function name. More recently, Yves started skipping "brick" from some of the newer terms, which I think is fine. Now we have a mix with names including "brick" and some without. Apart from that, there are 3 functions that do not follow the old naming convention at all:
I would like to avoid this kind of inconsistencies in the naming so that all functions for adding a PDE matrix either have "brick" at the end of their name or that they do not include it at all.
For Tetsuo's function I would suggest one of
Both in c++ and the interfaces.
What do you think?