|Subject:||Re: [Getfem-commits] please merge branch devel-tetsuo-add_lumped_mass_python_interface_squash|
|Date:||Fri, 16 Apr 2021 20:29:18 +0900|
I also think that these name changes are convenient.
On 10/04/2021 06:57, Tetsuo Koyama wrote:
Dear Kostas and Yves
@Kostas Thank you for your comment. It is a good point.
I am a fan of adding brick at the end of the methods.
If you don't mind I will fix the name of these methods in this branch.
Best regards Tetsuo
2021年4月10日(土) 4:24 Konstantinos Poulios <firstname.lastname@example.org>:
Dear Tetsuo and Yves
@Tetsuo thanks for this interface functions. I would like to use this opportunity to discuss about the word "brick" in the naming of our functions adding PDE term matrices. Traditionally, "brick" was only used at the end of the function name. More recently, Yves started skipping "brick" from some of the newer terms, which I think is fine. Now we have a mix with names including "brick" and some without. Apart from that, there are 3 functions that do not follow the old naming convention at all:
add_lumped_mass_brick_for_first_orderI would like to avoid this kind of inconsistencies in the naming so that all functions for adding a PDE matrix either have "brick" at the end of their name or that they do not include it at all.
For Tetsuo's function I would suggest one of
Both in c++ and the interfaces.
What do you think?
On Fri, Apr 9, 2021 at 11:23 AM Tetsuo Koyama <email@example.com> wrote:
Dear GetFEM project
I added the lumped mass for first order to the python interface.Could you merge devel-tetsuo-add_lumped_mass_python_interface_squash ?
-- Yves Renard (Yves.Renard@insa-lyon.fr) tel : (33) 04.72.43.87.08 INSA-Lyon 20, rue Albert Einstein 69621 Villeurbanne Cedex, FRANCE http://math.univ-lyon1.fr/~renard ---------
|[Prev in Thread]||Current Thread||[Next in Thread]|