[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] python3, and a gpg question

From: Mike Gorse
Subject: Re: [Duplicity-talk] python3, and a gpg question
Date: Fri, 17 May 2019 09:05:30 -0500 (CDT)
User-agent: Alpine 2.21 (LSU 202 2017-01-01)

Hi Aaron,

On 2019-05-10 11:54, Aaron via Duplicity-talk wrote:
Something like:

if not (sys.version_info[:2] >= (3, 5) or (sys.version_info[0] == 2 and sys.version_info[:2] >= (2, 7))):
    print("Sorry, duplicity requires version 3.5 or later of Python.")

is my understanding of how this check should work.

Okay. I already have a merge request open for other reasons, so I've added that check to my branch.

As for the other issue I was having, I filed it as lp#1828869 and also have a fix in my branch. It is also a regression in 0.7.19, but I haven't submitted a fix there so far--I figured I'd wait for a review first.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]