[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Duplicity-talk] python3, and a gpg question

From: Mike Gorse
Subject: [Duplicity-talk] python3, and a gpg question
Date: Thu, 9 May 2019 16:22:09 -0500 (CDT)
User-agent: Alpine 2.21 (LSU 202 2017-01-01)


I was just testing the imap backend on python 3 and had a couple of questions.

Setup.py now has this:
if sys.version_info[:2] < (3, 5):
    print("Sorry, duplicity requires version 3.5 or later of Python.")

This check currently excludes python 2. Is that intended? I thought that the plan was for 0.8 to support both python 2 and python 3. If 0.8 will actually be python 3 only, then that would probably make it easier to tidy up the code in some places, but tox.ini still specifies that the unit tests should also be run on 2.7.

Also, I've fixed a few issues with the back end in lp:~mgorse/duplicity/0.8-series (mostly string vs. bytes issues and email API changes), but I'm getting this error when running list-current-files:

GPGError: GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: AES encrypted data
gpg: gcry_kdf_derive failed: Invalid data
gpg: encrypted with 1 passphrase
gpg: decryption failed: No secret key
===== End GnuPG log =====

I'm wondering whether anyone has seen this; I'm puzzled by it, since it doesn't appear to be an issue of the back end corrupting the data, and restore works correctly despite list-current-files failing.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]