discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Illegal instruction when running plmerge or a built app


From: Alister Hood
Subject: Re: Illegal instruction when running plmerge or a built app
Date: Tue, 20 Mar 2012 10:38:30 +1300
User-agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120315 Firefox/11.0 SeaMonkey/2.8

OK, thanks, that seems more promising - no illegal instruction running plmerge when building things. But it still crashes when I try to run any app. After also rebuilding gnustep-gui with debugging enabled, here's what I get:

Program received signal SIGILL, Illegal instruction.
0xb7cfc9c3 in -[NSMenuView sizeToFit] ()
   from /opt/GNUstep/lib/libgnustep-gui.so.0.23
(gdb) bt
#0  0xb7cfc9c3 in -[NSMenuView sizeToFit] ()
   from /opt/GNUstep/lib/libgnustep-gui.so.0.23
#1  0xb7cf9cd3 in -[NSMenuView rectOfItemAtIndex:] ()
   from /opt/GNUstep/lib/libgnustep-gui.so.0.23
#2  0xb7cf7a8c in -[NSMenuView setNeedsDisplayForItemAtIndex:] ()
   from /opt/GNUstep/lib/libgnustep-gui.so.0.23
#3  0xb7cf7629 in -[NSMenuView itemChanged:] ()
   from /opt/GNUstep/lib/libgnustep-gui.so.0.23
#4  0xb786360f in ?? () from /opt/GNUstep/lib/libgnustep-base.so.1.25
#5  0xb78625f2 in ?? () from /opt/GNUstep/lib/libgnustep-base.so.1.25
#6  0xb7cf1c51 in -[NSMenu itemChanged:] (self=0x8136fbc, _cmd=0xb7f49778,
    anObject=0x82dcd9c) at NSMenu.m:846
#7 0xb7cff3dc in -[NSMenuItem setTarget:] (self=0x82dcd9c, _cmd=0xb7f49738,
    anObject=0x8136fbc) at NSMenuItem.m:464
#8 0xb7cfe49e in -[NSMenuItem setSubmenu:] (self=0x82dcd9c, _cmd=0xb7f45398,
    submenu=0x8297b2c) at NSMenuItem.m:237
#9  0xb7cf246e in -[NSMenu setSubmenu:forItem:] (self=0x8136fbc,
    _cmd=0x804ec70, aMenu=0x8297b2c, anItem=0x82dcd9c) at NSMenu.m:1005
#10 0x08048ca2 in main () at main.m:52


Date: Sat, 17 Mar 2012 23:33:48 -0600
From: Eric Wasylishen<address@hidden>
To: Discuss-gnustep Discuss<address@hidden>
Subject: Re: Illegal instruction when running plmerge or a built app
Message-ID:<address@hidden>
Content-Type: text/plain; charset=windows-1252

Hi Alister,

The illegal instruction in that backtrace is in the art graphics library 
backend of GNUstep, which is more or less deprecated / unmaintained. First 
thing I would try is installing cairo and re-run ./configure for your SVN 
checkout of gnustep-back - it should automatically detect and use cairo. Next 
make and install gnustep-back, and see if that fixes the problem.

Cheers,
Eric

On 2012-03-17, at 7:31 PM, Alister Hood wrote:

Hi, I'm trying to get started with Gnustep on Arch Linux (x86).
Whatever I try to build, there is an error like this:

/bin/sh: line 2: 23312 Illegal instruction plmerge 
GSTest.app/Resources/Info-gnustep.plist "GSTestInfo.plist"

And when I try to run the app that was built I just get an "illegal 
instruction".

I have tried with the official packages in Arch:
gnustep-back 0.20.1-1
gnustep-base 1.23.0-1
gnustep-gui 0.20.0-3
gnustep-make 2.6.1-1
I have also tried with self-built gnustep from svn, and got the same results.

Below is the output when I build the Calculator test with debugging enabled.
Does this indicate whether it is a problem with gnustep, or with some other 
dependency or something?

Thanks,
Alister


[Calculator]# make debug=yes
This is gnustep-make 2.6.1. Type 'make print-gnustep-make-help' for help.
Making all for app Calculator...
Creating Calculator.app/....
Compiling file main.m ...
main.m: In function ?main?:
main.m:32:22: warning: variable ?pool? set but not used 
[-Wunused-but-set-variable]
Compiling file CalcBrain.m ...
Compiling file CalcFace.m ...
Linking app Calculator ...
Creating Calculator.app/Resources...
Creating stamp file...
Creating Calculator.app/Resources/Info-gnustep.plist...
/bin/sh: line 2: 15844 Illegal instruction plmerge 
Calculator.app/Resources/Info-gnustep.plist "CalculatorInfo.plist"
make[2]: [Calculator.app/Resources/Info-gnustep.plist] Error 132 (ignored)
Creating Calculator.app/Resources/Calculator.desktop...
Copying resources into the app wrapper...
[Calculator]# debugapp ./*.app
GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later<http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from 
/src/gnustep-examples-1.3.0/gui/Calculator/Calculator.app/Calculator...done.
(gdb) run
Starting program: 
/src/gnustep-examples-1.3.0/gui/Calculator/Calculator.app/Calculator
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".

Program received signal SIGILL, Illegal instruction.
0xb6bb20a2 in artcontext_setup_gamma () from 
/usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020
(gdb) bt
#0 0xb6bb20a2 in artcontext_setup_gamma () from 
/usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020
#1 0xb6b9ddb9 in ?? () from 
/usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020
#2 0xb6b6bc5b in ?? () from 
/usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020
#3 0xb7c58834 in initialize_gnustep_backend () from 
/usr/lib/libgnustep-gui.so.0.20
#4 0xb7c592d2 in ?? () from /usr/lib/libgnustep-gui.so.0.20
#5 0xb78b8247 in ?? () from /usr/lib/libgnustep-base.so.1.23
#6 0xb7926a13 in ?? () from /usr/lib/libgnustep-base.so.1.23
#7 0xb7924238 in ?? () from /usr/lib/libgnustep-base.so.1.23
#8 0xb7925b8a in ?? () from /usr/lib/libgnustep-base.so.1.23
#9 0xb7c57b43 in ?? () from /usr/lib/libgnustep-gui.so.0.20
#10 0xb7c4fc9d in ?? () from /usr/lib/libgnustep-gui.so.0.20
#11 0x08048ab3 in main () at main.m:39



reply via email to

[Prev in Thread] Current Thread [Next in Thread]