[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Illegal instruction when running plmerge or a built app

From: Alister Hood
Subject: Illegal instruction when running plmerge or a built app
Date: Sun, 18 Mar 2012 14:31:04 +1300
User-agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120315 Firefox/11.0 SeaMonkey/2.8

Hi, I'm trying to get started with Gnustep on Arch Linux (x86).
Whatever I try to build, there is an error like this:

/bin/sh: line 2: 23312 Illegal instruction plmerge GSTest.app/Resources/Info-gnustep.plist "GSTestInfo.plist"

And when I try to run the app that was built I just get an "illegal instruction".

I have tried with the official packages in Arch:
gnustep-back 0.20.1-1
gnustep-base 1.23.0-1
gnustep-gui 0.20.0-3
gnustep-make 2.6.1-1
I have also tried with self-built gnustep from svn, and got the same results.

Below is the output when I build the Calculator test with debugging enabled.
Does this indicate whether it is a problem with gnustep, or with some other dependency or something?


[Calculator]# make debug=yes
This is gnustep-make 2.6.1. Type 'make print-gnustep-make-help' for help.
Making all for app Calculator...
Creating Calculator.app/....
Compiling file main.m ...
main.m: In function ‘main’:
main.m:32:22: warning: variable ‘pool’ set but not used [-Wunused-but-set-variable]
Compiling file CalcBrain.m ...
Compiling file CalcFace.m ...
Linking app Calculator ...
Creating Calculator.app/Resources...
Creating stamp file...
Creating Calculator.app/Resources/Info-gnustep.plist...
/bin/sh: line 2: 15844 Illegal instruction plmerge Calculator.app/Resources/Info-gnustep.plist "CalculatorInfo.plist"
make[2]: [Calculator.app/Resources/Info-gnustep.plist] Error 132 (ignored)
Creating Calculator.app/Resources/Calculator.desktop...
Copying resources into the app wrapper...
[Calculator]# debugapp ./*.app
GNU gdb (GDB) 7.4
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /src/gnustep-examples-1.3.0/gui/Calculator/Calculator.app/Calculator...done.
(gdb) run
Starting program: /src/gnustep-examples-1.3.0/gui/Calculator/Calculator.app/Calculator
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".

Program received signal SIGILL, Illegal instruction.
0xb6bb20a2 in artcontext_setup_gamma () from /usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020
(gdb) bt
#0 0xb6bb20a2 in artcontext_setup_gamma () from /usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020 #1 0xb6b9ddb9 in ?? () from /usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020 #2 0xb6b6bc5b in ?? () from /usr/lib/GNUstep/Bundles/libgnustep-back-020.bundle/./libgnustep-back-020 #3 0xb7c58834 in initialize_gnustep_backend () from /usr/lib/libgnustep-gui.so.0.20
#4 0xb7c592d2 in ?? () from /usr/lib/libgnustep-gui.so.0.20
#5 0xb78b8247 in ?? () from /usr/lib/libgnustep-base.so.1.23
#6 0xb7926a13 in ?? () from /usr/lib/libgnustep-base.so.1.23
#7 0xb7924238 in ?? () from /usr/lib/libgnustep-base.so.1.23
#8 0xb7925b8a in ?? () from /usr/lib/libgnustep-base.so.1.23
#9 0xb7c57b43 in ?? () from /usr/lib/libgnustep-gui.so.0.20
#10 0xb7c4fc9d in ?? () from /usr/lib/libgnustep-gui.so.0.20
#11 0x08048ab3 in main () at main.m:39

reply via email to

[Prev in Thread] Current Thread [Next in Thread]