[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OOT tests failing in GNU Radio, Ubuntu 20.04.2 LTS

From: Ron Economos
Subject: Re: OOT tests failing in GNU Radio, Ubuntu 20.04.2 LTS
Date: Sun, 27 Jun 2021 19:41:05 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.11.0

For gr-iqlevels, I never completed the QA test. You can make it pass by doing the following.

1) Install the OOT. In the build directory:

sudo make install

sudo ldconfig

2) Edit gr-iqlevels/python/qa_iqlevels.py. Change line 30 from:

instance = iqlevels()


instance = iqlevels(1000000,True)


On 6/27/21 6:32 PM, Anton Ottosson wrote:


I was working my way through the OOT module tutorial (https://wiki.gnuradio.org/index.php/OutOfTreeModules) when I ran in to an issue in the part about testing. Trying to run tests i get an error, and ctest -V reveals:

ModuleNotFoundError: No module named 'howto'

To ensure that the reason was not simply some mistake of mine during the tutorial I tried downloading and running tests on drmpeg/gr-iqlevels (https://github.com/drmpeg/gr-iqlevels). This module was mentioned in a thread (https://lists.gnu.org/archive/html/discuss-gnuradio/2021-05/msg00052.html) as a simple module that is ready for GNU Radio 3.9, so it seemed like a good condidate for experimentation. I got the same kind of error with this module. At the bottom of this message I have provided a dump of a terminal session where I go through this, from cloning the git repo to running the tests.

I am running Ubuntu 20.04.2 LTS, and installed GNU Radio via PPA. A message (https://lists.gnu.org/archive/html/discuss-gnuradio/2021-05/msg00056.html) in the thread mentioned earlier made me suspect that the issue might be with my installed version of pybind11-dev, so I made sure that I have version 2.5.0 and nothing else:

~$ dpkg -s pybind11-dev


Version: 2.5.0-4~ubuntu20.04.1~ppa1

But I still have the same issue, so that does not seem to be it. Does anyone here have any ideas what the issue might be?


~$ git clone git@github.com:drmpeg/gr-iqlevels.git
Cloning into 'gr-iqlevels'...
remote: Enumerating objects: 169, done.
remote: Counting objects: 100% (95/95), done.
remote: Compressing objects: 100% (64/64), done.
remote: Total 169 (delta 32), reused 70 (delta 26), pack-reused 74
Receiving objects: 100% (169/169), 204.81 KiB | 852.00 KiB/s, done.
Resolving deltas: 100% (48/48), done.
~$ cd gr-iqlevels/
~/gr-iqlevels$ mkdir build
~/gr-iqlevels$ cd build/
~/gr-iqlevels/build$ cmake ../
-- The CXX compiler identification is GNU 9.3.0
-- The C compiler identification is GNU 9.3.0
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Build type not specified: defaulting to release.
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Found LOG4CPP: /usr/lib/x86_64-linux-gnu/liblog4cpp.so
-- Checking for module 'gmp'
--   Found gmp, version 6.2.0
-- Found GMP: /usr/lib/x86_64-linux-gnu/libgmpxx.so  
-- Using GMP.
-- Found MPLIB: /usr/lib/x86_64-linux-gnu/libgmpxx.so  
-- Found Boost: /usr/lib/x86_64-linux-gnu/cmake/Boost-1.71.0/BoostConfig.cmake (found suitable version "1.71.0", minimum required is "1.71.0") found components: date_time program_options filesystem system regex thread unit_test_framework
-- Found Volk: Volk::volk  
-- User set python executable /usr/bin/python3
-- Found PythonInterp: /usr/bin/python3 (found version "3.8.5")
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython3.8.so (found suitable exact version "3.8.5")
-- Found Git: /usr/bin/git  
-- Extracting version information from git describe...
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython3.8.so
-- Using install prefix: /usr/local
-- Building for version: 801791d3 / 1.0.0git
-- No C++ unit tests... skipping
-- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
-- PYTHON and GRC components are enabled
-- Python checking for pygccxml - not found
-- Performing Test HAS_FLTO
-- Performing Test HAS_FLTO - Success
-- LTO enabled
-- Configuring done
-- Generating done
-- Build files have been written to: /home/antonott/gr-iqlevels/build
~/gr-iqlevels/build$ make
Scanning dependencies of target gnuradio-iqlevels
[ 12%] Building CXX object lib/CMakeFiles/gnuradio-iqlevels.dir/iqlevels_impl.cc.o
[ 25%] Linking CXX shared library libgnuradio-iqlevels.so
[ 25%] Built target gnuradio-iqlevels
Scanning dependencies of target pygen_apps_9a6dd
[ 25%] Built target pygen_apps_9a6dd
Scanning dependencies of target pygen_python_6c177
[ 37%] Generating __init__.pyc
[ 50%] Generating __init__.pyo
[ 50%] Built target pygen_python_6c177
Scanning dependencies of target iqlevels_docstrings
[ 62%] Copying iqlevels docstring templates as pybind headers ...
copy docstrings to /home/antonott/gr-iqlevels/build/python/bindings/iqlevels_pydoc.h
[ 62%] Built target iqlevels_docstrings
Scanning dependencies of target iqlevels_python
[ 75%] Building CXX object python/bindings/CMakeFiles/iqlevels_python.dir/iqlevels_python.cc.o
[ 87%] Building CXX object python/bindings/CMakeFiles/iqlevels_python.dir/python_bindings.cc.o
[100%] Linking CXX shared module iqlevels_python.cpython-38-x86_64-linux-gnu.so
[100%] Built target iqlevels_python
~/gr-iqlevels/build$ ctest -V
UpdateCTestConfiguration  from :/home/antonott/gr-iqlevels/build/DartConfiguration.tcl
UpdateCTestConfiguration  from :/home/antonott/gr-iqlevels/build/DartConfiguration.tcl
Test project /home/antonott/gr-iqlevels/build
Constructing a list of tests
Done constructing a list of tests
Updating test list for fixtures
Added 0 tests to meet fixture requirements
Checking test dependency graph...
Checking test dependency graph end
test 1
    Start 1: qa_iqlevels

1: Test command: /usr/bin/sh "/home/antonott/gr-iqlevels/build/python/qa_iqlevels_test.sh"
1: Test timeout computed to be: 10000000
1: Traceback (most recent call last):
1:   File "/home/antonott/gr-iqlevels/python/qa_iqlevels.py", line 12, in <module>
1:     from iqlevels import iqlevels
1: ModuleNotFoundError: No module named 'iqlevels'
1: During handling of the above exception, another exception occurred:
1: Traceback (most recent call last):
1:   File "/home/antonott/gr-iqlevels/python/qa_iqlevels.py", line 18, in <module>
1:     from iqlevels import iqlevels
1: ModuleNotFoundError: No module named 'iqlevels'
1/1 Test #1: qa_iqlevels ......................***Failed    0.30 sec

0% tests passed, 1 tests failed out of 1

Total Test time (real) =   0.30 sec

The following tests FAILED:
      1 - qa_iqlevels (Failed)
Errors while running CTest

reply via email to

[Prev in Thread] Current Thread [Next in Thread]