[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OOT tests failing in GNU Radio, Ubuntu 20.04.2 LTS

From: Anton Ottosson
Subject: Re: OOT tests failing in GNU Radio, Ubuntu 20.04.2 LTS
Date: Mon, 28 Jun 2021 15:29:27 +0000

Hi, and thank you for making me feel welcome! I have already gotten help from Ron, the author of gr-iqlevels. Though unfortunately, due to not being able to open mailto links with with the Outlook web app, I responded to him with a different email address, and therefore our discussion has not been included in the mailing list correctly. Hopefully I am responding in a correct way now. Below I will outline the solution for posterity.

Ron suggested using cmake -DCMAKE_INSTALL_PREFIX=/usr ../ with the motivation "Since you're using the ppa, you installed in the wrong directory.". So for gr-iqlevels the following sequence gets us past the error:

git clone git@github.com:drmpeg/gr-iqlevels.git
cd gr-iqlevels/
mkdir build
cd build
sudo make install
ctest -V

Now, the test will still fail because the QA class have actually not been implemented (its just the template generated by gr_modtool). But if line 30 of gr-iqlevels/python/qa_iqlevels.py is changed to instance = iqlevels(1000000,True) then the test goes through.

Ron also suggested using sudo ldconfig after sudo make install. This does not seem to make any difference for me though, and I am not sure if ldconfig actually even does anything (it outputs nothing to terminal).

Providing the install prefix to cmake also resolved the corresponding issue with the tutorial howto module, as expected. (I still initially ran into issues with an "Unable to coerce endpoints"  error, but this was resolved when I restarted the tutorial from the  beginning, so it was probably due to some silly mistake that I wasn't  able to identify.)

Best regards,

From: Vasil Velichkov <vvvelichkov@gmail.com>
Sent: Monday, June 28, 2021 1:24:44 PM
To: Anton Ottosson; discuss-gnuradio@gnu.org
Subject: Re: OOT tests failing in GNU Radio, Ubuntu 20.04.2 LTS
Hi Anton,

Welcome to GNU Radio!

On 28/06/2021 04.32, Anton Ottosson wrote:
> I was working my way through the OOT module tutorial (https://wiki.gnuradio.org/index.php/OutOfTreeModules) when I ran in to an issue in the part about testing. Trying to run tests i get an error, and ctest -V reveals:
> ModuleNotFoundError: No module named 'howto'

Can you share the full output (not just this error) and the source code of your OOT in a github/gitlab repository?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]