[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Getting OOT's to run in GRC

From: John Murphy
Subject: Getting OOT's to run in GRC
Date: Sun, 13 Jun 2021 07:34:48 -0400

Hello list,

I have been unable to get any OOT module blocks to run in GRC.

I initially was using a VirtualBox Manjaro (via Architect) with GNURadio 3.9 and with some finding missing packages (cmake, swig, boost, boost-libs maybe some others Ive forgotten) was able to get gr_modtool created blocks to compile and link and install with no error messages. The blocks pull in gr-fft and (for the lfsr stuff) gr-digital. There is a source block, a general block, and a couple noblock utility classes in the custom OOT module.
But when I attempt to run a flowgraph containing these OOT blocks in GRC I get the "module attribute error module has no component block" (sic).
I followed some hints I researched for adding a conf file to ld.so.d to add /usr/local/lib and did that and restarted my system to take effect then did ldconfig. But no change in result.

Being unsure of all the things that may be misconfigured I decided to try a VirtualBox Ubuntu LTS with (aside from gcc make perl for the vbox guest additions) only the gnuradio ppa installed.
My first attempt was with 3.9 via the master branch using the basic instructions (3 cli commands) at the top of https://wiki.gnuradio.org/index.php/UbuntuInstall then recreating my OOT module with gr_modtool. But gr_modtool couldn't do newmod because of some missing template or some such which seems to still be a problem.
So I made a new Ubuntu LTS VM and tried to use the ppa for gnuradio 3.7 but discovered there are no sources in that ppa so it would not install.

Finally I remembered Goldilocks and the Three Bears and tried yet another VM with the ppa for gnuradio 3.8 hoping it would be just right. With this I was able to use gr_modtool to set up the OOT module and add the blocks, copy my C++ code over, and do the compile, link, install, ldconfig.
But on this system running a flowgraph in GRC containing blocks from the OOT I get the "no module named module" (sic) import error where it can't even find the entire OOT module. I found one suggested fix with some path variables which did seem useful (both the PYTHONPATH and LD_something_blah_blah paths were empty). But taking the steps to temporarily fix the paths did not remedy the error message.

I don't understand a lot about python or the inner workings of the C++ cmake build system set up by gr_modtool. Way back in the day I managed to build gnuradio on some Fedora boxes using the build-gnuradio script and gnuradio 3.7.something and gr_modtool and with probably headaches I don't remember anymore managed to get custom OOT module blocks on those machines up and running pretty well. But I'm stumped now.

My preference is to get this to work in Manjaro (current with linux 5.10.something), but if that can't be done then getting it to work in Ubuntu LTS (20.04 or if an older LTS version works better let me know) will have to do.
Would someone give me some ideas to try?

Many thanks,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]