[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Getting OOT's to run in GRC

From: John Murphy
Subject: Re: Getting OOT's to run in GRC
Date: Mon, 14 Jun 2021 07:44:52 -0400

Thanks Vasil.
That worked for the Manjaro system which is what I wanted. FYI had to also add analog to the find_package as cmake threw an error without it so it must be a dependency of one of those others.
Also for posterity I tried this in the Ubuntu LTS (ubuntu 20.04 gr 3.8) VM but the Ubuntu LTS VM still can't get past the ModuleNotFound for my OOT module when starting the flowgraph in GRC. But overcome by events since it works in Manjaro which was just having the attribute error for the blocks not the modulenotfound error.

On Mon, Jun 14, 2021 at 3:16 AM Vasil Velichkov <vvvelichkov@gmail.com> wrote:
Hi John,

On 13/06/2021 14.34, John Murphy wrote:
>  The blocks pull in
> gr-fft and (for the lfsr stuff) gr-digital. There is a source block, a
> general block, and a couple noblock utility classes in the custom OOT
> module.
> But when I attempt to run a flowgraph containing these OOT blocks in GRC I
> get the "module attribute error module has no component block" (sic).

One possible reason is that you have undefined references in the .so file. To resolve this you need to link both gr-fft and gr-digital. In you top level CMakeLists.txt you need to add gr-fft and gr-digital in the Gnuradio's find_package list.

  find_package(Gnuradio "3.8" REQUIRED COMPONENTS blocks filter fft digital)

And then in lib/CMakeLists.txt you need to link those to your OOT module

  target_link_libraries(myOOTblocks gnuradio::gnuradio-runtime gnuradio::gnuradio-fft gnuradio::gnuradio-digital)

Also open python/__init__.py and change

  except ImportError:


  except ModuleNotFoundError:

See also https://wiki.gnuradio.org/index.php/GNU_Radio_3.8_OOT_Module_Porting_Guide#GNU_Radio_Components


John Murphy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]