[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bugs in DDD on the mac (10.5, leopard, intel core 2)

From: David Clarke
Subject: bugs in DDD on the mac (10.5, leopard, intel core 2)
Date: Mon, 16 Mar 2009 14:34:15 -0300

Dear address@hidden;

For those following my thread on how to install ddd from the www.gnu.org/software/ddd website, I have since tried downloading ddd using "sudo port install ddd", and this seems to have worked, at least to get me to where I can get a ddd window to open up. To be clear, I could *not* get the download instructions on the gnu.org website to work (they are incomplete), but the port install command seems to have worked.

Having said that, there seems to be numerous bugs with ddd as it is manifest on the mac.

1. The usual controls on the windows do not work. Thus, I cannot resize the window by dragging the bottom right corner, I can't move the ddd window from my laptop screen to my big screen by dragging the window over (it stops at the location of the mouse arrow, and won't move any further).

3. When another window (e.g., mail) is over the ddd window, the ddd tooltips still show up over top the mail window as though the mail window were not there.

4. When a secondary window is brought up (e.g., source -> breakpoints), the close control doesn't do anything. I have to hit the red circle at the top left of the window to disappear it. (However, the close button on the help windows work...)

5. When I set a breakpoint, the stop sign appears as expected, but when I hit cont and the execution stops at the stop point, there is nothing to indicate execution has stopped at the breakpoint. I would have expected a little arrow next to the break point, for example, to indicate which of the many set breakpoints execution has stopped at.

6. When I highlight a variable (in this case "cputot") and ask to have its value printed or displayed, I get: "No symbol "cputot" in current context", which is nonsense.

7. My ddd window seems to be divided into two regions. The top where the source appears, and the bottom where the gdb statements are echoed. However, when I try to scroll in the bottom gdb window, the scrolling affects the source window above. I cannot scroll the gdb window at all.

Then, under the category of "how do you do..."

1. How does one set a breakpoint at the top of a program module not currently printed in the source window? (dbx command "stop in <function>")

2. How does one set a conditional break point: "stop at line 23 if i=12", for example?

3.  Indeed, how does one show line numbers?

I have the impression I have a mac-incompatible version, or perhaps port install grabbed a very old version [I have DDD 3.3.11 (i686-apple- darwin9.4.0)]. Or perhaps there is a flag to have been set somewhere that the sudo port install failed to set.

Thanks to anyone with any answers and ideas!

Cheers, David.

Thank you for your response.

In step 3 you said that did a "configure" and "make" but no "make install" after that.To install the compiled programs(ddd) you need to give the command "make install".
This will install the ddd binary in you /usr/local/bin.

Frustrating that the simple line

make install

wasn't included as a fourth line in the installation instructions on the DDD web page.

So I did this, more messages flew by the screen, and it seemed to finish successfully. Indeed, a ddd* does appear in my /usr/local/bin

Then, going to the directory in which the executable to be debugged resides, I have the following session:

mytikas 10> ddd xedit21
Error: No `Ddd' application defaults file
To resolve this problem, you can:
* set the XAPPLRESDIR environment variable to the location of the file `Ddd', or * set the DDD_HOME environment variable to the location of `ddd/ Ddd', or
* install the `Ddd' file in the X application defaults directory, or
* recompile DDD with builtin app-defaults file;
 see the `--enable-builtin-app-defaults' option for details.
mytikas 11>

and so I have replaced one gotcha for another! Alas, I don't understand *any* of the suggestions.

Can you tell me what I should do now?

Also to verify you ddd binary is build properly, after doing a make you can do a "make check".This creates a sample C++ program `cxxtest' and then runs DDD on it by invoking `./ddd cxxtest'.

Again, "make check" causes more things to flash by the screen then, when it tries to launch ./ddd cxxtest, I end up with the same error message as above.

Again, any suggestions you or others may have would be greatly appreciated. I am desperately seeking my first real "success" at downloading *something* useful to, what is quickly becoming, this "stupid mac"!

cheers, David
ddd mailing list

David A. Clarke                                                 address@hidden
Professor of Astronomy and Physics              (902) 420-5830
Institute for Computational Astrophysics                (902) 496-8218 (fax)
Saint Mary's University                                 
Halifax, NS, B3H 3C3

reply via email to

[Prev in Thread] Current Thread [Next in Thread]