[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

compiling ddd on centos 5

From: Rob Messer
Subject: compiling ddd on centos 5
Date: Mon, 25 Jun 2007 23:22:59 -0700
User-agent: Thunderbird (Windows/20070604)

I am running CentOS 5 (which is basically the same as RedHat EL5), with xorg-x11 7.1 and gnome. I have tried to configure ddd-3.3.11, as well as 3.3.11-test2 and 3.3.11-test5. When I run ./configure, it fails (for all 3 versions) at this point:

checking for XOpenDisplay in -lX11... no
configure: error: The X11 library '-lX11' could not be found.
                 Please use the configure options '--x-includes=DIR'
                 and '--x-libraries=DIR' to specify the X location.
                 See the files 'config.log' and 'ddd/config.log'
                 for further diagnostics.

I've have openmotif-2.3 installed via an rpm package. I tried using lesstif as well, but it failed to compile, saying "The development package of the X Window System is required to compile LessTif, must be at least X11r5." So it doesn't look like I can use lesstif in this environment.

So I'm guessing some things have changed in xorg x11 version numbering and library locations, and this is causing the problem. I tried setting --x-includes and --x-libraries to a few different things but to no avail.

Any ideas to work around this or what to set x-libraries and x-includes to? Anyone get ddd to compile under CentOS 5 or RedHat Enterprise Linux 5? Thanks,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]