[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling ddd on centos 5

From: Tim Mooney
Subject: Re: compiling ddd on centos 5
Date: Wed, 27 Jun 2007 16:29:30 -0500 (CDT)

In regard to: compiling ddd on centos 5, Rob Messer said (at 11:22pm on Jun...:

I am running CentOS 5 (which is basically the same as RedHat EL5), with xorg-x11 7.1 and gnome. I have tried to configure ddd-3.3.11, as well as 3.3.11-test2 and 3.3.11-test5. When I run ./configure, it fails (for all 3 versions) at this point:

checking for XOpenDisplay in -lX11... no
configure: error: The X11 library '-lX11' could not be found.
                Please use the configure options '--x-includes=DIR'
                and '--x-libraries=DIR' to specify the X location.
                See the files 'config.log' and 'ddd/config.log'
                for further diagnostics.


Did you do what the message suggests, and look in the config.log and
ddd/config.log?  If you search in config.log for XOpenDisplay, you'll
probably find something along the lines of:

configure:27702: checking for XOpenDisplay in -lX11
configure:27732: g++ -o conftest -O2 -Wall -fpermissive conftest.cc -lX11  -lSM -lICE 

Followed by a compile or link error.  It's this error that is causing the
problem you're running into.

I think you should be fine using OpenMotif.

Any ideas to work around this or what to set x-libraries and x-includes to? Anyone get ddd to compile under CentOS 5 or RedHat Enterprise Linux 5? Thanks,

I'm building it under RHEL 5 right now, and didn't encounter the problem
you did.

By any chance, did you forget to install




?  Those packages will be needed for building any software like ddd.
Also, you are building a 32 bit ddd on a 32 bit install of CentOS 5,

Tim Mooney                              address@hidden
Information Technology Services         (701) 231-1076 (Voice)
Room 242-J6, IACC Building              (701) 231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164

reply via email to

[Prev in Thread] Current Thread [Next in Thread]