[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cjk] Fwd: HELP with emacs 25.1 and cjk-enc.el

From: Bo-Yin Yang
Subject: Re: [cjk] Fwd: HELP with emacs 25.1 and cjk-enc.el
Date: Mon, 12 Dec 2016 13:50:15 +0800

Dear all...

I think that after I retrofitted my Mac book using Mac ports with emacs 24.5 and no other change ... everything worked as before.

 did I clear up anything or confuse the issue even further?


On Dec 12, 2016 11:37 AM, "Hin-Tak Leung" <address@hidden> wrote:
On Sat, 10/12/16, Werner LEMBERG <address@hidden> wrote:

> You did :-)

:-). Apparently my local cjk-enc.el v4.8.2 is completely in sync with upstream
4.8.4 (except the version string, and part of a comment).

I tried running older emacs binaries on fedora 25, but no luck -
older emacs running on new system behaves the new way :-(.

However, I found that one simple change:

--- a/emacs/cjk-enc.el
+++ b/emacs/cjk-enc.el
@@ -876,7 +876,7 @@
         ;; some progress information if we have done another 1000
         ;; characters.
         (set-buffer temp-buf)
-        (if (> (- (point) last-pos) 1000)
+        (if (> (- (point) last-pos) 10000000)
               (setq last-pos (point))
               (message "Converting: %2d%%"

allows my old Thai sample to work. Somehow the progress message
"Converting..." is getting into,and overwriting the beginning of the output file,
This change simply disables the progress message updates.

Disabling the progress message doesn't fix the big5 input files from the original poster;
but setting LC_CTYPE=zh_TW.Big5 LC_ALL=zh_TW.Big5 does get the output
to be somewhat closer to desired (from my default LANG=en_GB.UTF-8).
Maybe the small change above improves his situation.

So this bug appears to be at least two problems - the progress message buffer
trashing the beginning of the output file, and emacs's sensitivity to LANG/LC_* .

I was hoping that if I could get the older emacs binaries to run, I could compare
the two side by side. But somehow older emacs on newer system behaves
the new way :-(. This seems to suggest it may not be a problem of emacs itself,
but one of the system's international libraries which emacs depends on.
I can run the older emacs 23 and 24.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]