[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: suggestion about nameing MU_STREAM_READ/WRITE...

From: Alain Magloire
Subject: Re: suggestion about nameing MU_STREAM_READ/WRITE...
Date: Sun, 3 Jun 2001 11:47:45 -0400 (EDT)


> I was going through my notes, and maybe I'm a luser, but it took
> me an hour of tracing through the code at one time to figure
> out this, so:
> Since supplying MU_STREAM_READ|MU_STREAM_WRITE causes mboxes to look
> empty, perhaps it can be an error? I expect read and write. I
> know it's like the unix file open flags (now) but the UNIX flags
> are O_RDONLY and O_WRONLY, which suggest that they don't mix,
> whereas read+write==read-AND-write... not.
> My suggestion:
> 1 - check for (currently) subtly meaningless combination of
> 2 -
>  a) change names to MU_STREAM_RDONLY and MU_STREAM_WRONLY
>  -or-
>  b) make MU_STREAM_READ|MU_STREAM_WRITE legal, and mean read+write,
>     and for backwards compatibility leave MU_STREAM_RDWR but define

(b) sounds good.  Lets go this way for the new mailbox API.

> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: attachment; filename="rdwr.diff"

Looks good, you should apply it to the current mailbox/*.
CVS is working for you right?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]