[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GRUB doesn't boot to Windows (with Solaris/Windows dual boots)

From: phil007
Subject: Re: GRUB doesn't boot to Windows (with Solaris/Windows dual boots)
Date: Wed, 25 Apr 2007 18:42:52 -0700 (PDT)


I have the same issue, my menu.lst is very similar to the previous post, i
have 1 hd with xp and one separate hd with solaris 10.
I have tried editing with the text you gave adrian but it still does not
load windows from the grub menu, i have to change the order of the hd's in
the bios to boot windows. 
All combinations of (hd1,0) and (hd0,1) have not worked after trying to load
it will either say that option does not exist or grub freezes after i select
xp or it complains about unrecognised for map (hd0) (hd1) or map (hd1)

Currently my  bios boot order is:
2 Maxtor with solaris
1 windows xp pro

Please help, how can i get xpto boot properly with grub?

Thanks in advance


adrian15 wrote:
> jennywongus escribió:
>> I have changed the bios  setting to boot the second disk
>> first (so that the boot always start from GRUB, otherwise, if
>> first disk is set to boot first, it'd boot to windows directly).
>> title Windows
>>         rootnoverify (hd0,0)
>>         chainloader +1
>> # Unknown partition of type 15 found on /dev/rdsk/c1d0p0 partition: 2
>> # It maps to the GRUB device: (hd0,1) .
> When Windows is on a second hard disk the right piece of menu.lst is:
> title Winodws
> map (hd0) (hd1)
> map (hd1) (hd0)
> rootnoverify (hd1,0)
> chainloader +1
> boot
> Enjoy!
> adrian15
> _______________________________________________
> Bug-grub mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/bug-grub

View this message in context: 
Sent from the Grub - Bugs mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]