[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] FTGL

From: Jon Kinsey
Subject: Re: [Bug-gnubg] FTGL
Date: Sun, 18 Sep 2005 12:38:32 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041206 Thunderbird/1.0 Mnenhy/0.7

Øystein Johansen wrote:
> Jon Kinsey wrote:
>>>I've had a look and the problem is not obviously with FTGL, it could be
>>>freetype or the way FTGL uses freetype.  So check if you can get a newer
>>>version of freetype 2, to see if this helps.
> I'm using the freetype from the GTK-devel package at
> http://gladewin32.sf.net. Is there a later package available somewhere?

I was aiming that comment more at the other people with problems

>>>On my mingw system it breaks when more than 2 fonts are used in FTGL.  I
>>>use 4 in gnubg, I've added a hack to lower the fonts down to 2, just add:
>>>#define FTGL_BROKEN 1
> I tried that and it then it works, but I get no numbered points on the
> board edge, and the fonts does not look antianialised.

There should be numbered points (i.e. something is going wrong).

>>>Interestingly it runs ok in gdb, if you can, try rebuilding with debug
>>>symbols and running in the debugger to see if it works like this - not
>>>sure what this will prove...
> What should I check in gdb?

That was what was strange.  When I run through gdb it works, outside gdb
it doesn't...

>>>>Another thing: The cube numbers look really nice, but the resignation
>>>>flag numbers are not antianialised.
>>>Not sure why I didn't do this.  I've just added the code to make the
>>>flag numbers look nice, I'll blame you if this breaks anything :-)
> I also try to recompile without the FTGL_BROKEN flag. If works fine, but
> the numbers are not filled.
> http://www.gnubg.org/media/myboard.png

This is still the same (similar) problem.  The 4 fonts used are
cube-outline, cube-fill, point-outline, point-fill.  It seems like some
of these randomly fail.

Note that using msdev to build, I get no problems at all.

I think there is just a random memory type problem in the freetype
library.  The FTGL code is quite straight forward and I can't see
anything that could be going wrong.  On the other hand the freetype
library is anything but straight forward...


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]