[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25081: Anybody needs help to set up a qemu VM for GNU/Hurd?

From: Paul Eggert
Subject: bug#25081: Anybody needs help to set up a qemu VM for GNU/Hurd?
Date: Wed, 7 Dec 2016 16:45:30 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1

On 12/07/2016 03:00 PM, Svante Signell wrote:
Hi, adding emacs-devel to the recipients

I'm not sure emacs-devel is worth bothering over all the details here, so I'll drop it from the CC: list for now. We can send emacs-devel a summary later as needed.

I normally use:
qemu-system-x86_64 -enable-kvm -m 2048 -net nic,model=rtl8139 -net
user,hostfwd=tcp::<port>-:22 -drive

Thanks, that wasn't obvious, I used that. Perhaps make it part of the brief HOWTO?

This is expected, since qemu does not know exactly in what format the file is
in. Maybe just ignore that warning for now? I (and others) do.

I'm a fan of fixing warnings; otherwise I find that I stop paying attention to them. Surely there's some option I can give to qemu to suppress the warning, and that could be part of the HOWTO?

It might be easier to use the debian tools:

I assume these commands need to be run as root on the guest.

apt-get update
apt-get dist-upgrade

These work, thanks. The latter takes a looong time. Perhaps this should be written down too.

apt-get build-dep emacs24/emacs25

This fails with 'Reading package lists... Done
E: Unable to find a source package for emacs24/emacs25'. I forged ahead by running just "apt-get build-dep emacs25" but that failed with:

E: Failed to fetch http://httpredir.debian.org/debian/pool/main/libx/libxdmcp/libxdmcp-dev_1.1.2-1.1_hurd-i386.deb Error reading from server. Remote end closed connection [IP: 80] E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
E: Failed to process build dependencies

I tried running "apt-get build-dep emacs25" again. This time it finished.

apt-get source emacs24/emacs25

I don't want to do this, as I want to build from the master branch. I did that, with plain 'configure; make'.

Emacs built and eventually attempted to dump itself, and while it was doing so, the operating system crashed. When I attempted to reboot, fsck failed. I ran fsck -y by hand (took a while) and rebooted. When the OS came back up, temacs was size-0, so I removed it and ran 'make' again. This time it worked, in the sense that I can now run Emacs in a tty window.

So, it sounds like we can declare victory against this bug, at least for the master branch. At least, it worked for me, if you ignore the OS crashing during the build. Possibly the crash was because I didn't reboot after the 'apt-get dist-upgrade' (you didn't say to reboot, so I didn't....).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]