bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25081: Anybody needs help to set up a qemu VM for GNU/Hurd?


From: Paul Eggert
Subject: bug#25081: Anybody needs help to set up a qemu VM for GNU/Hurd?
Date: Wed, 7 Dec 2016 14:36:57 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1

I tried to get a qemu VM running for GNU/Hurd on my platform (Fedora 24 x86-64), and did not succeed.

The instructions in https://people.debian.org/~sthibault/hurd-i386/installer/cdimage/ talk about running "apt-get install qemu-kvm". Obviously this won't work on Fedora. I'm not a big fan of virtualization to be honest, but after messing with it a bit I found that the following Unix shell commands sort-of worked:

sudo dnf install @virtualization

qemu-kvm -net user,hostfwd=tcp:127.0.0.1:2222-:22 -net nic -drive file=debian-hurd-20160824.img,cache=writeback -m 1G

The latter command outputs the somewhat scary-looking:

WARNING: Image format was not specified for 'debian-hurd-20160824.img' and probing guessed raw. Automatically detecting the format is dangerous for raw images, write operations on block 0 will be restricted.
         Specify the 'raw' format explicitly to remove the restrictions.

and gives me a screen where I can log in as root and type the command "password demo" to change the password, and then from another terminal window I can run "ssh address@hidden -p 2222" to login to GNU/Hurd, and after creating .ssh/authorized_keys with my key, I can run "scp -P 2222 emacs.tar.gz address@hidden:". (This "emacs.tar.gz" was created by running "make dist" followed by "tar cf emacs.tar.gz emacs-26.0.50" on my development machine, in the master branch.) Although all this is obvious if you're a VM expert and like messing with VMs, it's not written down in the instructions. (Plus, I hate having to type Ctrl-Alt-G all the time while configuring the VM -- that's not documented either.)

On GNU/Hurd I tried several ways to configure Emacs. None worked. I made the most progess with this:

tar xf emacs.tar.gz

cd emacs-26.0.50

./configure --without-x --with-gnutls=no

This failed as follows:

checking for library containing tputs... no
configure: error: The required function 'tputs' was not found in any library.
The following libraries were tried (in order):
  libtinfo, libncurses, libterminfo, libtermcap, libcurses
Please try installing whichever of these libraries is most appropriate
for your system, together with its header files.
For example, a libncurses-dev(el) or similar package.

At this point I gave up. I don't know where to grab GNU/Hurd packages from, and anyway this process is taking more of my time than I would like to spend.

Perhaps you could build a GNU/Hurd image that already has all the packages needed to develop programs like Emacs, and then send a complete standalone recipe that will let someone easily reproduce the Emacs problem even if they dislike messing with VMs.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]