bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23290: 25.1.50; eww: Symbol’s value as variable is void: url-http-re


From: Tao Fang
Subject: bug#23290: 25.1.50; eww: Symbol’s value as variable is void: url-http-response-status
Date: Wed, 20 Apr 2016 00:41:06 +0800
User-agent: Emacs/Gnus

Michael Heerdegen <address@hidden> writes:

> Tao Fang <address@hidden> writes:
>
> You made me distrustful.  I have rebuilt master (without your patch) and
> with the gnutls dev lib deinstalled (to get to the original environment
> where I had discovered the problem) - and the problem is gone.  The
> function you changed in your patch is not called at all.

Yes, it won't trigger in your case (not using proxy), but it's a bug, I
think it should be fixed ASAP.

@Lars Ingebrigtsen: Can you help to check and push the fix to trunk?

> Dunno what is different from some days ago.  Either there is a
> difference with that url, or the daily upgrades of my Debian testing are
> related (For what it's worth, for two days or so Emacs was building with
> Lucid instead of Gtk, now, it builds with Gtk again.  I didn't specify
> any configure options.  So a relation to my OS seems not preempted to
> me.)

Back to the error message you provided in the beginning, the reason was
simlar to the above(I think?).

Maybe anybody familiar with this can help?

> Hmm.  Anything more I can do?

Here is my suggestion:
    (setq debug-on-error t)
    (setq url-debug 1)
    and when the problem occurs, save the content of buffer "*Messages*"
    and "*Backtrace*"
With more information, this bug can be located more quickly.

Thanks for your help!

-- 
Emacs/Gnus





reply via email to

[Prev in Thread] Current Thread [Next in Thread]