bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23290: 25.1.50; eww: Symbol’s value as variable is void: url-http-re


From: Michael Heerdegen
Subject: bug#23290: 25.1.50; eww: Symbol’s value as variable is void: url-http-response-status
Date: Sat, 16 Apr 2016 16:08:48 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.92 (gnu/linux)

Tao Fang <address@hidden> writes:

> > Here is a URL for that I can reproduce the problem:
> >
> >   https://lite.qwant.com/?t=images&q=test
> I'm assuming the reproduce step of this issue is: using eww open that
> url directly after starting up emacs with "emacs -Q" ?

Yes.

> > Configured features:
> > XPM JPEG TIFF GIF PNG RSVG IMAGEMAGICK SOUND DBUS GSETTINGS NOTIFY
> > LIBXML2 FREETYPE XFT ZLIB TOOLKIT_SCROLL_BARS GTK3 X11
> I've noticed that your configure doesn't have "GNUTLS" support, if
> you're using "url-proxy-services", it will produce message like "error:
> gnutls support needed" in buffer "*Messages*" (which I got when trying
> to reproduce this with same configure).

Maybe my OS (Debian testing) is missing some dev packages?  FWIW, I
don't see this error in the emacs-25 branch.


> > Repository revision: d6ea6453f3d1696b9e6cd0a0222fc77dc646365c
> I've compiled emacs with git commit
> d6ea6453f3d1696b9e6cd0a0222fc77dc646365c and configure
> "--without-gnutls" but didn't reproduce this.  And I had also tried to
> set up a proxy (https://github.com/tinyproxy/tinyproxy), and still no
> luck with some simple test.

AFAICT, there is nothing special with my system, since I don't know much
about such stuff.  I'm not using a proxy.

> Can you provide more information about this? With following settings:
>     (setq debug-on-error t)
>     (setq url-debug 1)
> and when the problem occurs, save the content of buffer "*Messages*"
> and "*Backtrace*", then paste it here?

Sure, I have to bootstrap master for that again (I'm currently not
working with master since it has some more bugs bothering me too much).

> There is also a bug report bug#23225, I don't know if it's related to
> this commit, but I will try to work it out.

Ok, will have a look.


Regards,

Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]