[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Commit problem

From: Nick
Subject: Re: Commit problem
Date: Thu, 25 Dec 2003 03:15:06 GMT
User-agent: Pan/0.13.96 (You appear to be in death, comrade.)

Hi Paul,

I've been using CVS for ~8 months at home and at work w/out problems (of
this nature).  I haven't used it at home for ~2 months and now it exhibits
this problem.  During that time, I've upgraded CVS, coreutils, and some
CVS still works properly at work, where none of the aforementioned
upgrades were applied.

So I'm confident that it's something specific to my home PC.  The test
script for this problem is to simply create a multi-level dir tree for the
repository, change a file in each directory, and attempt to commit all
from the top via 'cvs commit'.  That's as simple as it gets.  My CVS no
longer detects all files that changed upon commit (though it does for
'diff' or 'update').

As mentioned in another post, I tried reverting to a 'fundamental' setup
to no avail.  I tried a separate, clean CVS, a new user, restored the
previous fileutils, all w/ no success.
I've been stepping through CVS w/ a debugger for several hours in search
of a clue.  Unfortunately, I'm still learning CVS' internal workings.

One thing I noticed is the latest version of coreutils reports the date
stamp of a file differently than the one shipped w/ Red Hat 7.2.  Instead
it's now
    YYYY MMM DD Time

I wonder if CVS uses or depends on this for anything.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]