[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20570: Test dd/sparse.sh fail with btrfs

From: Sébastien Luttringer
Subject: bug#20570: Test dd/sparse.sh fail with btrfs
Date: Thu, 14 May 2015 04:53:57 +0200


I experience one test suite failure when I tried to rebuild the
coreutils v8.23 package. My system is an archlinux host with a btrfs

The test doesn't fail when I run it in a tmpfs. I'm pretty sure it used
to works over btrfs in july 2014[1] when I built the previous package
for archlinux.

The failing section is the following:

  # Ensure NUL blocks smaller than the block size are not made sparse.
  # Here, with a 2MiB block size, dd's conv=sparse must *not*
introduce a hole. 
  dd if=file.in of=file.out bs=2M conv=sparse
  test 2500 -lt $(kb_alloc file.out) || fail=1

You can see the full shell output here: http://pastebin.com/XADb1BKj


[1] https://www.archlinux.org/packages/core/x86_64/coreutils/

Sébastien "Seblu" Luttringer
https://seblu.net | Twitter: @seblu42
GPG: 0x2072D77A

reply via email to

[Prev in Thread] Current Thread [Next in Thread]