[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20570: Test dd/sparse.sh fail with btrfs

From: Pádraig Brady
Subject: bug#20570: Test dd/sparse.sh fail with btrfs
Date: Thu, 14 May 2015 11:48:30 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

On 14/05/15 03:53, Sébastien Luttringer wrote:
> Hello,
> I experience one test suite failure when I tried to rebuild the
> coreutils v8.23 package. My system is an archlinux host with a btrfs
> filesystem.
> The test doesn't fail when I run it in a tmpfs. I'm pretty sure it used
> to works over btrfs in july 2014[1] when I built the previous package
> for archlinux.
> The failing section is the following:
>   # Ensure NUL blocks smaller than the block size are not made sparse.
>   # Here, with a 2MiB block size, dd's conv=sparse must *not*
> introduce a hole. 
>   dd if=file.in of=file.out bs=2M conv=sparse
>   test 2500 -lt $(kb_alloc file.out) || fail=1
> You can see the full shell output here: http://pastebin.com/XADb1BKj
> Regards,
> [1] https://www.archlinux.org/packages/core/x86_64/coreutils/

It seems the allocation is async.
I also see this intermittently with BTRFS on 4.0.0-0.rc5.git4.1.fc22.x86_64
I've been unable to reproduce with the attached
which syncs the file before checking the allocation.


Attachment: dd-sparse-btrfs.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]