[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

installing CommonC++2-1.3.9 on arm board

From: Roger Cortesi
Subject: installing CommonC++2-1.3.9 on arm board
Date: Tue, 26 Jul 2005 11:02:56 -0400
User-agent: Mozilla Thunderbird 1.0 (Windows/20041206)

Hi there, I hope this is the appropriate forum.

I'm trying to install the GNU Commom C++ Library on an ARM
board to take advantage of the serial port rountines in it.

The arm aboard is running debian

I have to cross compile it on a cygwin system because the arm
is really slow at compiling.

I'm trying to use Commoncpp2-1.3.9

on the cygwin box I ran:

./configure --target=arm --prefix=/blaablaa blaa
make install

I copied the the *.h files to /usr/include/cc++
and the *.lo files to /usr/lib/cc++

Then I ran "ldconfig" to update the linker cache

Now on the ARM board I wrote a simple test c++ program

#include <iostream>
#include <cc++/serial.h>
using namespace std;

int main(void)
   count << "Hello Roger, I'm testing the serial.h lib\n";
   return 0;

I realize that my use of TTYSession is likely dorked up, but
if that was my only compile problem I would be ok.

So when I tried to compile it with g++ got the error that

in cc++/config.h "bits/atomicity.h" Not Found!

So some digging in config.h and I find on line 229
with a comment that says set to 1 one if you have this file.
I have set this to 0

and further down on line 262
I commented out this line and uncommented

And then on line 1051
#include <bits/atomicity.h>

So this file should not be included any more

but now when I complile I get these errors:

In file included from /usr/include/cc++/missing.h:42,
                from /usr/include/cc++/serial.h:47,
                from test.cpp:2:
/usr/include/cc++/config.h:817: conflicting types for `typedef int socklen_t' /usr/include/unistd.h:247: previous declaration as `typedef __socklen_t socklen_t'
In file included from /usr/include/cc++/serial.h:51,
                from test.cpp:2:
/usr/include/cc++/thread.h:327: syntax error before `;'
test.cpp: In function `int main()':
test.cpp:9: implicit declaration of function `int TTYSession(...)'

what is up with the conflicting typedef for socklen_t? should the one in unistd.h also be an int?

Any thoughts on that syntax error in thread.h line 327/

Here is the code from thread.h
327        pthread_RWLOCK_T _lock;
328    #else
329        Mutex mutex;
330    #endif

sorry this is so long and thanks for any help/insight you can offer.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]