|Subject:||Re: [PATCH] Make AC_COMPUTE_INT public|
|Date:||Thu, 22 Jun 2006 09:27:01 +0200|
|User-agent:||Thunderbird 220.127.116.11 (Macintosh/20060530)|
I have a problem with the change. The public AC_COMPUTE_INT macro should use AC_MSG_CHECKING and AC_MSG_RESULT to announce what it's doing. Arguably, it should also cache the value of VARIABLE.Agreed, on both counts.
I'd rather leave this to the caller. In particular, it's not very easy to find a name for the cache variable without breaking compatibility with earlier users of _AC_COMPUTE_INT. For example, AC_CHECK_ALIGNOF uses "(long int) offsetof (ac__type_alignof_, y)" as the argument, no matter what type's alignment is being tested.
In other words, I see more similarity between AC_COMPUTE_INT and AC_RUN_IFELSE than, say, between AC_COMPUTE_INT and AC_CHECK_SIZEOF.
|[Prev in Thread]||Current Thread||[Next in Thread]|