[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Problems with missmatching hashes

From: Maarten Bezemer
Subject: Re: [rdiff-backup-users] Problems with missmatching hashes
Date: Sun, 17 Jul 2011 00:38:39 +0200 (CEST)

Hi Christian,

On Sat, 16 Jul 2011, Christian Kölpin wrote:

Warning: Computed SHA1 digest of <File>
doesn't match recorded digest of
Your backup repository may be corrupted!

ok i do some more investigation.
I changed from xfs to ext4 (just to check).

Then i do a clean backup again (from scratch). Run --verify and again
some mismatching SHA1 occurs.
To check the files i run "cmp <source> <backup>', and i get, that there
are some bytes changed. The files have exactly the same size but some
bytes are "changed". I run e2checkfs, but it says "all fine".

Has anyone some idea?

My first guess would be bad ram. Run memtest86+ for at least 12 hours (or less if it reports problems, no point in testing bad ram for more errors).

Other things to check would be your power supply, the timings for cpu, ram, and bus, or ide/sata cables and connections.

You could also try to find reports of other people getting corruption or instability issues with your type of mainboard, chipset, ram, etc. I've had timing issues with Via chipsets in the past, that didn't show up in memtest, but got several faulty md5sums of a 100MB file when repeatedly checking it. Underclocking the ram to match cpu core speed solved that issue. (Happened consitently with several mainboards and several brands of ram, my ram was fine...)

If you don't get memtest errors, report back here with some more info about your hardware.

Memtest can be downloaded at: www.memtest.org

Hope this helps..


reply via email to

[Prev in Thread] Current Thread [Next in Thread]