[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Mouse support on the console?

From: Morten Bo Johansen
Subject: Re: lynx-dev Mouse support on the console?
Date: Mon, 17 Jan 2000 19:55:21 +0100

Thanks for your generous help.

This stuff is giving me grey hairs: I fetched ncurses ver. 5.0, compiled it
--with-gpm and installed it (the ncurses installation apparently defaults to
just overwriting the old one so I took a chance and my system works fine)

Anyway, Lynx mouse-support on the console still doesn't work so I have a
couple of further questions:

The ncurses compilation has created the following libs

libform.a       libmenu.a       libncurses++.a  libncurses_g.a  libpanel_g.a
libform_g.a     libmenu_g.a     libncurses.a    libpanel.a

and they're all installed in /usr/lib

However, some debris from the SuSE installation remains - the
in /usr/lib is still a softlink to /lib/ which is from my
SuSE installation and the Lynx which I compiled anew following the ncurses
installation is still linked to this old version:

# ldd lynx => /lib/ (0x4001e000)

No wonder mouse support still doesn't work. Could you tell me which of the
above mentioned libraries from the ncurses compilation that I should
softlink to

Klaus Weide <address@hidden> said:

> $ nm -D /usr/local/lib/|grep -i gpm
>          U Gpm_GetEvent
>          U Gpm_Open
> 000157c0 T _nc_set_gpm_connect
>          U gpm_fd

I get this from my self-compiled libncurses.a:

# nm libncurses.a |grep gpm

00000004 b gpm_connect
         U gpm_fd

O.k. ?

> Oh yeah - you may *also* have to re-generate your libgpm library (or

I deinstalled the SuSE gpm-package (not really knowing if it contains the
neccessary libraries - there is only one gpm package in SuSE) and then I
compiled and installed gpm ver. 1.18.0



reply via email to

[Prev in Thread] Current Thread [Next in Thread]