[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Argh! FTP problems...

From: Paul D. Smith
Subject: lynx-dev Argh! FTP problems...
Date: Wed, 13 May 98 13:14:22 EDT

Well, I was just about to throw every bit of code related to the web off
all my systems, with prejudice, last night.

Netscape is core dumping on my system about 25% of the time when I try
to download a file via ftp.

So, I've been using Lynx (2.7 and 2.8) for this.  However, I had lots of
problems with that, too, most of which could be fairly easily solved.
I've read the help pages, Al Gilman's picks, and noted the Lynx FAQ was
pretty bare of information about these issues.

Also, I should point out that I'm using Lynx from a "global" install,
where hundreds of people are using the same installation.  It's quite
annoying that so much of Lynx's configuration is not user-customizable:
there are many things in lynx.cfg that I wish I could change in
.lynxrc.  And recompiling to change userdefs.h is right out.

 1) Lynx downloaded the file OK (it was a .tar.gz file).  It then tried
    to uncompress the file, which I didn't want it to do.  I can't find
    any way to modify this behavior; do I have to modify ~/.mailcap or
    something?  Where is this documented?  I have a .mime.type set up
    for this extension (.tar.gz), but nothing in .mailcap (well, I have
    an x-mozilla-flags=save, but I assume Lynx isn't looking at that).

 2) When Lynx tried to uncompress the file, it failed to do so.  The
    error message it printed was overwritten so fast I had no chance
    whatsoever to read it.  I saw the info about INFOSECS, MESSAGESECS,
    and ALERTSECS, but this message was gone before even 1 second had
    elapsed, much less 2 or 3.

 2a) In Lynx 2.7, after whatever happened caused a failure of the
     uncompress, Lynx deleted the downloaded file!  So I got nothing.
     Bogus.  Luckily, when I compiled 2.8 that file wasn't deleted
     (although it did have a temporary name), otherwise I'd _still_ not
     have a copy...

     At the very least, Lynx should ask before deleting that file it
     just spent so much time downloading for me.

 3) I determined that the problem was it was downloading and trying to
    decompress in my /tmp directory, which is on my root filesystem and
    is too small.  That's why I set the environment variable TMPDIR to a
    different directory: almost all UNIX apps honor TMPDIR for temporary
    files, if it's set.  It's extremely annoying that Lynx doesn't do so.

 4) Nowhere in any of the installed documentation can I find the
    description of the various environment variables Lynx understands.
    Note I don't have the source code; I've installed Lynx for many
    users in a global area and deleted the source, as I always do.

    It's quite bogus that _vital_user_information_ for using Lynx, like
    these all-important environment variables, is buried in the
    INSTALLATION file and doesn't appear anywhere in the on-line help,
    HTML help, or in the ENVIRONMENT section of the man page for Lynx,
    etc.  Even if _I_ still had the build tree, no one else would!

 5) So I set LYNX_TEMP_SPACE to be $TMPDIR, but it still failed.  Again,
    I have no idea what error it's printing, as it disappears so
    quickly, but something is not right besides the disk space issue.

    However, by now I was using Lynx 2.8 so the file wasn't deleted.  I
    was able to uncompress/untar it myself (it was a valid file), to
    finally succeed in getting a copy of the file.

Quite a frustrating evening, overall :-/.

If I'm overlooking some obvious resource, I'd be happy to hear about

 Paul D. Smith <address@hidden>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
     These are my opinions--Bay Networks takes no responsibility for them.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]