[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev Argh! FTP problems...

From: Doug Kaufman
Subject: Re: lynx-dev Argh! FTP problems...
Date: Wed, 13 May 1998 19:26:05 -0700 (PDT)

On Wed, 13 May 1998, Paul D. Smith wrote:

>  1) Lynx downloaded the file OK (it was a .tar.gz file).  It then tried
>     to uncompress the file, which I didn't want it to do.  I can't find
>     any way to modify this behavior; do I have to modify ~/.mailcap or
>     something?  Where is this documented?  I have a .mime.type set up
>     for this extension (.tar.gz), but nothing in .mailcap (well, I have
>     an x-mozilla-flags=save, but I assume Lynx isn't looking at that).

Lynx tries to uncompress gzip files only when you click on the link. If
you use the "D" download command, you will get the file unmodified (at
least with the current version).
>  2) When Lynx tried to uncompress the file, it failed to do so.  The
>     error message it printed was overwritten so fast I had no chance
>     whatsoever to read it.  I saw the info about INFOSECS, MESSAGESECS,
>     and ALERTSECS, but this message was gone before even 1 second had
>     elapsed, much less 2 or 3.

What happens depends on how you built and configured lynx. If you
built with the zlib option, the decompression is done within lynx.
Otherwise it looks for the gunzip that you specified in lynx_cfg.h (as
UNCOMPRESS_PATH). By default, lynx uses the full pathname, so if you
changed the directory or name of the file, this may fail. If you still
have lynx_cfg.h, you can see if this is a valid path and filename, with
appropriate permissions. If not, you can probably find it with a strings
command and search for gunzip.

Doug Kaufman
Internet: address@hidden (preferred)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]