[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Commit Problem

From: Bill Smith
Subject: Re: Commit Problem
Date: Thu, 5 Dec 2002 16:24:50 -0500

----- Original Message -----
From: "Mike Ayers" <address@hidden>
To: "Bill Smith" <address@hidden>
Cc: <address@hidden>
Sent: Thursday, December 05, 2002 3:51 PM
Subject: Re: Commit Problem

> Please send only plain text messages to technical mailing lists.  Thanks.

New install. My mistake. I didn't realize it was still enabled. Thx.

> Bill Smith wrote:
> > Below is a message I posted to the tortoise cvs mailing list.
> >
> > Additionally, I tried doing a cvs commit with cygwin cvs, I get
> >
> > /CVSROOTccess /var/cvs
> > No such file or directory
> This is not a cut-and-paste of the output.  Please send a
> cut-and-paste of the output, or reproduce the output faithfully.
> Approximate error messages do not help.

Actually, yes it is a cut-and-paste, here it is again including the command

$ cvs commit
cvs commit: Examining .
address@hidden's password:
/CVSROOTccess /var/cvs
No such file or directory

Here s the entire trace with the -t option

$ cvs -t commit
cvs commit: notice: main loop with
cvs commit: Examining .
 -> Starting server: ssh -l bsmith cvs server
address@hidden's password:
/CVSROOTccess /var/cvs
No such file or directory

FYI, the cygwin cvs version is

$ cvs -v

Concurrent Versions System (CVS) 1.11 (client/server)

> > I know there is some inconsistency between the cvs cygwin cvs client and
> > the cvsnt client
> > but searching, it's not clear to me what those inconsistencies are. Can
> > anyone clarify them?
> If you find this out, please tell us.   :-)  (Other than the line
> ending issue, that is).


> > -----------------------------------------
> > I have a strange one here. I have a group of jpg images that I'm adding
> > to a repository. When I do a "cvs add", all the images add fine. When I
> > try and commit, I get the error below for certain files. (I only see the
> > message below if I commit them one at a time, when in a group, I get
> > generic message).
> >
> > What is weird is that in some cases, if I open the image in an editor
> > resave it (change jpg params) and try and commit, it will work. This
> > be a coincidence.
> What params are you changing?  Opening a JPEG file in an editor and
> resaving it should change nothing.

I played with changing the compression level of the jpg using the gimp. cvs
SHOULDN'T care anyway. It's a
> > Additional Info:
> >   TortoiseCVS version 1.2.1
> >   client os: Windows XP Home
> >   server os: Redhat 7.2
> >   server ssh version: OpenSSH_3.1p1
> Server CVS version?

server cvs version is 1.11.1p1

> Client/server protocol?  :ext: with ssh is implied, but you give an
> OpenSSH version, and TortoiseCVS only works with PLINK.EXE, which does
> not show an OpenSSH version.

On the client side, TortoiseCVS is using plink which is connecting to sshd
on the server side.
This has worked successfully with all the other files. To add some more
detail, it is only a
handful of files (~12 out of 100) all jpgs that are acting up. The images
all vary in size, but
none exceed 30 - 40k.

> > Any ideas? Honestly, I don't think this is a TortoiseCVS problem, but
> > instead
> > a generic cvs problem, but I was hoping someone on this list might have
> > ideas. I'm also gonna post this on the cvs list.
> *cough*  Or generic pilot error?  Just make sure you double check
> your setup.

This may be true. (it's always a possibility :) However, what gives me pause
is that it
is just certain files. As mentioned above, other files in the same
directory, created the
same way, can be added and committed fine.

I have a number of other modules (mix of file types including jpgs) that
work fine.

Since we are talking configuration, fyi, in the server cvswrappers file is
an entry
for jpgs:
*.jpg -k 'b'

> > ------------------------
> > In C:\Projects\webv3: "C:\Program Files\TortoiseCVS\cvs.exe" commit -m
> > "" src/html/gallery/images/sunfun/009_6a.jpg
> > CVSROOT=:ext:address@hidden:/var/cvs
> >
> > cvs commit: warning: unrecognized response `FATAL ERROR: Server sent
> > disconnect message:
> > ' from cvs server
> > cvs commit: warning: unrecognized response `"Corrupted check bytes on
> > input."
> > ' from cvs server
> > cvs [commit aborted]: end of file from server (consult above messages if
> > any)
> Check bytes?  Smells like client/server incompatibility to me.
> /|/|ike

reply via email to

[Prev in Thread] Current Thread [Next in Thread]