[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs repository in a bad state, and cvs seg faults on export of pr

From: Larry Jones
Subject: Re: cvs repository in a bad state, and cvs seg faults on export of pr
Date: Wed, 2 May 2001 10:49:20 -0400 (EDT)

Ryan Grow writes:
> We are having problems with one of our working areas. The developer told me
> that he tried to rename several files from being lower case to having a
> leading upper case letter.

This currently doesn't work on case preserving but case insensitive
systems (i.e., Windows).  CVS was originally designed to be case
sensitive and, although it tries to handle case insensitive systems, it
doesn't quite handle this case correctly.

> He told me that he removed the files with the cvs remove and commit
> commands. But then when he attempted to add the new files with the new name,
> he got the following failure message:
> cvs commit -m "" Threats_warnings_completion.cfm
> cvs commit: [14:29:51] waiting for rgrow's lock in
> /usr/local/cvsroot/web_reports/htdocs/reports

Not initially -- that's a result of the crash you mention later.  The
original error message should have been something like "cannot add file
when RCS file already exists".

> Another symptom, is when I do a cvs update in the working area of this
> project, I see several lines of messages like this:
> cvs update: nothing known about htdocs/reports/Physical_IO_statistics.cfm
> This is the name of the file that he had intended to add.

That's another symptom of the case sensitivity difficulties -- CVS
sort-of knows about the file (because there's a file in the repository
with the same name if you ignore case differences), but doesn't really
know about it (because of the case differences).

> Another symptom is that cvs will seg fault when I try to export this
> project. It progresses the export until it gets to the directory containing
> the files in question, at which point it seg faults. This happens if I run
> the cvs client on linux. If I run it on windows, it crashes in the same
> place with the message: 'Terminated with fatal signal 11'.

If you know how to use a debugger to get a traceback from the crash,
please send it to address@hidden so we can track down and fix the

> I'd appreciate any advice on how to restore the repository to a clean state
> from this locking problem.

You'll need to remove the stale lock files by hand.  See:

After that, I think your only option is to manually rename the
repository files (which is less than desirable since you lose the
previous spelling of the name).

-Larry Jones

I keep forgetting that rules are only for little nice people. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]