[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cvs repository in a bad state, and cvs seg faults on export of pr oject

From: Ryan Grow
Subject: cvs repository in a bad state, and cvs seg faults on export of pr oject
Date: Tue, 1 May 2001 14:34:38 -0600


We are having problems with one of our working areas. The developer told me
that he tried to rename several files from being lower case to having a
leading upper case letter.
He told me that he removed the files with the cvs remove and commit
commands. But then when he attempted to add the new files with the new name,
he got the following failure message:

cvs commit -m "" Threats_warnings_completion.cfm
cvs commit: [14:29:51] waiting for rgrow's lock in

Another symptom, is when I do a cvs update in the working area of this
project, I see several lines of messages like this:

cvs update: nothing known about htdocs/reports/Physical_IO_statistics.cfm

This is the name of the file that he had intended to add.

Another symptom is that cvs will seg fault when I try to export this
project. It progresses the export until it gets to the directory containing
the files in question, at which point it seg faults. This happens if I run
the cvs client on linux. If I run it on windows, it crashes in the same
place with the message: 'Terminated with fatal signal 11'.

We are using CVS 1.11 on Redhat Linux 7.0 for the repository.

I'd appreciate any advice on how to restore the repository to a clean state
from this locking problem.

Ryan Grow

reply via email to

[Prev in Thread] Current Thread [Next in Thread]