[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: cvs history -f command

From: Abhay Jain
Subject: RE: cvs history -f command
Date: Thu, 4 Jan 2001 15:53:36 -0700

Thanks Larry.

I was using the "T" option which is not associated with file types, so I was
getting all records.
When I tried 

cvs history -x AMG <filename>

it worked fine.

For the -b option, it seems like it only returns the last updated matching
record (not all matching records) and also that a string cannot begin with a
number. Is that true ?


-----Original Message-----
From: address@hidden [mailto:address@hidden
Sent: Thursday, January 04, 2001 15:45
To: address@hidden
Cc: address@hidden
Subject: Re: cvs history -f command

Abhay Jain writes:
> Actually I am specifying the argument for report type.
> I tried:
> cvs history -e -a
> cvs history -x ATMG -a
> all these commands with and without -f <filename> or just <filename> give
> the same result.
> (they display all the files matching the criteria)

What version of CVS are you using?  F, O, E, and T records do not have
associated file names, so asking for any of those types of records will
get you all of them.  C, G, U, W, A, M, and R records do have associated
filenames and will be limited to those contaning the specified string. 
This definitely works with CVS 1.11 -- it's possible that there are bugs
in previous versions.

> It makes me believe that somehow the filenames also need to be specified
> the "modules" file or somewhere else, otherwise they are not recognized
> string comparison purposes (-f or -b options of history). Is that true ? I
> have only defined the module names in the "modules" file.

No.  history doesn't look at the modules file, only the history file.

-Larry Jones

Summer vacation started!  I can't be sick! -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]