[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vile] Here is the file which demonstrates the insert bug

From: Thomas Dickey
Subject: Re: [vile] Here is the file which demonstrates the insert bug
Date: Wed, 23 Apr 2008 11:01:51 -0400 (EDT)

On Wed, 23 Apr 2008, Chris G wrote:

On Wed, Apr 23, 2008 at 03:18:02PM +0100, Chris G wrote:

I can't get it to hang, but I did find a possibly-related bug: if I
enter non-ASCII codes (in uxterm, locale en_US.UTF-8), inserting into
the quoted area, the insertion point jumps to the end of the line
about the point where the (folded) line is pushed to the right-margin.

Here's a "before":
<                          <li><a href="ìììììììììììììììììììì">Pictures</a></li>
...and the "after":
<                          <li><a
<                          href="íííííííííííííííííííí">Pictures</a></li>í

( So there's something I can investigate ;-)

I have just tried it on my work system, fedora 7, and it happens just
the same there too.  I also tried in an xterm, still the same.

Further I have just downloaded and built vile 9.5 and that doesn't
have the bug.  I'll try an unpatched 9.6.

That might be worse: the bug that I can see is going to be due to one
of the multibyte adjustments.  There's a place in the code where (if
the adjustment isn't right), the cursor will jump to the end of the line.
I've fixed a couple of those since 9.6

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]