[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] TCC compile error

From: Conrado Miranda
Subject: Re: [Tinycc-devel] TCC compile error
Date: Thu, 10 May 2007 16:06:07 -0300

It worked now with that link.
I had some problem with pthreadtypes.h but I found how to solve on the list.

Ty man and everybody that puts time on tcc :D

On 5/9/07, Rob Landley <address@hidden> wrote:
On Wednesday 09 May 2007 3:47 pm, Conrado Miranda wrote:
> On 5/9/07, Rob Landley <address@hidden> wrote:
> > On Wednesday 09 May 2007 3:14 pm, Conrado Miranda wrote:
> > > Something was wrong with my update script, but I updated to glibc 2.5
> > > and guess what? More erros =(
> > > The 'make test' ran ok again, but when I tried 'tcc ex1.c', I got
> > > those errors messages.
> >
> > Ok, the first problem is:
> >   tcc: file 'AS_NEEDED' not found
> >   /usr/lib/libc.so:3: filename expected
> >   /usr/lib/libc.so:3: unrecognized file type
> >
> > Could you send us your /usr/lib/libc.so file?  (It should be a smallish
> > file, specifically a linker script.)
> >
> > Looks like it grew new knobby bits tcc isn't parsing yet...
> >
> > Rob
> >
> >
> Sorry, man. I haven't seen that there was an error on that file. You
> know, bosses don't like when I are doing something that isn't your
> work :D
> But here it is:
> /* GNU ld script
>    Use the shared library, but some functions are only in
>    the static library, so try that secondarily.  */
> OUTPUT_FORMAT(elf32-i386)
> GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a  AS_NEEDED (
> /lib/ld-linux.so.2 ) )

Support for that kind of AS_NEEDED was added in 2005, back before Fabrice got
too busy with QEMU to work on tcc.  In my repository, it's this commit:


I have personally tested my tcc fork on Ubuntu 7.04, which has a libc.so that
looks exactly like that and is using gcc 2.5.  To confirm it, I just fired up
qemu and built examples/ex5.c with tcc on that and it built fine.

Would you please once again confirm that you are using something more recent
than 2005?  (Not just that you built it but that you actually installed it,
and aren't getting an old one out of the $PATH?)  Because it's really,
really, really looking like you're using an old version with bugs long-since


reply via email to

[Prev in Thread] Current Thread [Next in Thread]