[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

help with gettext and make distcheck

From: Gavin Smith
Subject: help with gettext and make distcheck
Date: Tue, 15 Dec 2015 16:52:26 +0000

What a mess. I've tried upgrading gettext, but when I run "make dist"
I get the error:

test ! -f texinfo.po || { \
  if test -f ../../../po/texinfo.pot-header; then \
    sed -e '1,/^#$/d' < texinfo.po > texinfo.1po && \
    cat ../../../po/texinfo.pot-header texinfo.1po > texinfo.po; \
    rm -f texinfo.1po; \
  fi; \
  if test -f ../../../po/texinfo.pot; then \
    sed -f remove-potcdate.sed < ../../../po/texinfo.pot > texinfo.1po && \
    sed -f remove-potcdate.sed < texinfo.po > texinfo.2po && \
    if cmp texinfo.1po texinfo.2po >/dev/null 2>&1; then \
      rm -f texinfo.1po texinfo.2po texinfo.po; \
    else \
      rm -f texinfo.1po texinfo.2po ../../../po/texinfo.pot && \
      mv texinfo.po ../../../po/texinfo.pot; \
    fi; \
  else \
    mv texinfo.po ../../../po/texinfo.pot; \
  fi; \
rm: cannot remove '../../../po/texinfo.pot': Permission denied
make[5]: *** [texinfo.pot-update] Error 1
make[5]: Leaving directory

I've tried two or three times, running autoconf, running gnulib-tool
--add-import, following steps at
but no success: I get the same error each time.

This is an old problem, see

If anyone remembers the right way to do this, please say so, otherwise
I'll just have to keep trying until I succeed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]