[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [STUMP] Stumpwm won't start

From: Paul R. Bernard
Subject: Re: [STUMP] Stumpwm won't start
Date: Sun, 20 Sep 2009 14:08:51 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

Dirk Sondermann <address@hidden> writes:

> Shawn Betts wrote:
>> On Sun, Sep 20, 2009 at 3:54 AM, Paul R. Bernard <address@hidden> wrote:
>>> I'm using (on gentoo linux):
>>> stumpwm HEAD is now at 9d6cb38 bump version to 0.9.7-git
>>> sbcl 1.0.19
>>> cl-clx 0.7.1
>>> xorg 7.2
>>> At startup I receive the following error and backtrace:
>> This is a problem that has started popping up now and then. It seems
>> the way stumpwm detects fonts is somehow flawed. It thinks certain
>> fonts exist when they don't. I'm curious if perhaps there's a font
>> package on gentoo that you haven't installed?

> "9x15bold" is part of media-fonts/font-misc-misc.
> This package used to be a dependency of x11-base/xorg-server, but
> since version 1.5, it has to be emerged explicitly.

Thank you Dirk.  This fixed the problem and stumpwm is now working.

Another kind person pointed out that I was running archaic versions
(from the main gentoo package repository) of sbcl and clx and modern
versions could be found in the "lisp" gentoo portage overlay.

Shawn, I don't know how you are supposed to detect fonts, but last night
before I ran out of steam I tried "xfd -fn 9x15bold" and it clearly
indicated that the font was missing.  It's there now. :-)

Thank you all,

- paul

reply via email to

[Prev in Thread] Current Thread [Next in Thread]