[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] "Found too many current_mirror incs!"

From: Dominic Raferd
Subject: Re: [rdiff-backup-users] "Found too many current_mirror incs!"
Date: Thu, 4 May 2017 06:39:53 +0100

On 3 May 2017 at 22:28, Ron Leach <address@hidden> wrote:

> On 02/05/2017 23:42, Dominic Raferd wrote:
>> I suggest you take a backup of the existing broken repository and then try
>> on it the latest version of my script which can be obtained from
>> http://www.timedicer.co.uk/programs/help/rdiff-backup-regress.sh.php.
> Dominic, I fetched the latest script from your site, thank you. Having
> backed up the destination directory, and removed an old current_mirror.*
> file, I ran your script to take away the latest increment.  But the script
> aborted saying it could not find the destination.  So I tried with
> rdiff-backup --check-dest... using the same destination and that did find
> the destination (but aborted saying 'no need to check').
> Here's a transaction sequence:
> Server5:/home/ron#
> ​​
> ./rdiff-backup-regress.sh -n 1 address@hidden::/srv/Data/101vmail
> rdiff-backup-regress.sh v1.0 [25 Aug 2016] by Dominic (-h for help)
> =======================
> Cannot find directory "address@hidden::/srv/Data/101vmail", aborting...
> Server5:/home/ron# rdiff-backup --check-destination-dir -v3
> address@hidden::/srv/Data/101vmail
> Fatal Error: Destination dir /srv/Data/101vmail does not need checking
> Server5:/home/ron# Fatal Error: Lost connection to the remote system
> ^C
> Server5:/home/ron# ./rdiff-backup-regress.sh -n 1 address@hidden:
> :/srv/Data/101vmail
> rdiff-backup-regress.sh v1.0 [25 Aug 2016] by Dominic (-h for help)
> =======================
> Cannot find directory "address@hidden::/srv/Data/101vmail", aborting...
> Server5:/home/ron#
> SSH from machine ...101 to ...201 works with user certificates - and I
> tested that again to make sure there was no remote login problem.  I'd
> taken the script's command format from the example on the script webpage,
> substituting '1' for the '2' in the example (as you can see).  I have also
> used the script in the past (very likely an earlier version), and all our
> backups are onto other machines, and all have used the 
> address@hidden::/destination/path
> type of construction.  I'm assuming the script should be run from the
> machine that initiates the backup - is that correct?  Or should I be doing
> this differently?

​The script needs to run locally on the machine that hosts the repository,
sorry - I will update the help info to clarify this. So you need to do
something along these lines:

# log in to hosting server
ssh address@hidden
# obtain script locally (on server)
wget -O rdiff-backup-regress.sh
# make it executable
chmod +x ./rdiff-backup-regress.sh
# run it
​./rdiff-backup-regress.sh /srv/Data/101vmail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]