[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] IOError: [Errno 28] No space left on device: None -

From: Joost van den Broek
Subject: [rdiff-backup-users] IOError: [Errno 28] No space left on device: None -- OS: win32
Date: Mon, 29 Oct 2007 11:23:36 +0100
User-agent: Thunderbird (X11/20070804)


This error occurs since a few weeks on one of my maintained systems,
which indeed ran out of space (well, 2GB of free space, but it needs to
backup more than that, so it makes sense). This one was running version
1.1.12, so the --tempdir parameter was not yet recognized. Unfortunately
after upgrading to 1.1.14 and specifying a tempdir with more than enough
space available, the same error appeared.

I also tried to set TMP and TEMP on the cmd-line, but it doesn't help.
So I guess it's always using the same (hard coded?) tempdir on win32, no
matter what tempdir or env vars are specified. Is this a bug, or am I
doing something wrong?

BTW. I've put all necessary files into a MSI package, so there is no
need to run a complete Cygwin environment:
You need to examine rdiff-backup.bat if you've specified or renamed the
default path to other than c:\rdiff-backup.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]