[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-ppc] [PATCH 08/13] spapr: Consolidate construction of /chosen
From: |
David Gibson |
Subject: |
Re: [Qemu-ppc] [PATCH 08/13] spapr: Consolidate construction of /chosen device tree node |
Date: |
Fri, 21 Oct 2016 12:41:43 +1100 |
User-agent: |
Mutt/1.7.0 (2016-08-17) |
On Thu, Oct 20, 2016 at 09:49:42AM +0200, Thomas Huth wrote:
> On 20.10.2016 07:12, David Gibson wrote:
> > For historical reasons, building the /chosen node in the guest device tree
> > is split across several places and includes both parts which write the DT
> > sequentially and others which use random access functions.
> >
> > This patch consolidates construction of the node into one place, using
> > random access functions throughout.
> >
> > Signed-off-by: David Gibson <address@hidden>
> > ---
> > hw/ppc/spapr.c | 131
> > ++++++++++++++++++++++-----------------------
> > hw/ppc/spapr_vio.c | 17 ++----
> > include/hw/ppc/spapr_vio.h | 2 +-
> > 3 files changed, 70 insertions(+), 80 deletions(-)
> >
> > diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c
> > index 2faae32..c608ec8 100644
> > --- a/hw/ppc/spapr.c
> > +++ b/hw/ppc/spapr.c
> > @@ -273,14 +273,10 @@ static void add_str(GString *s, const gchar *s1)
> >
> > static void *spapr_create_fdt_skel(sPAPRMachineState *spapr)
> > {
> > - MachineState *machine = MACHINE(spapr);
> > void *fdt;
> > - uint32_t start_prop = cpu_to_be32(spapr->initrd_base);
> > - uint32_t end_prop = cpu_to_be32(spapr->initrd_base +
> > spapr->initrd_size);
> > GString *hypertas = g_string_sized_new(256);
> > GString *qemu_hypertas = g_string_sized_new(256);
> > uint32_t refpoints[] = {cpu_to_be32(0x4), cpu_to_be32(0x4)};
> > - unsigned char vec5[] = {0x0, 0x0, 0x0, 0x0, 0x0, 0x80};
> > char *buf;
> >
> > add_str(hypertas, "hcall-pft");
> > @@ -337,35 +333,6 @@ static void *spapr_create_fdt_skel(sPAPRMachineState
> > *spapr)
> > _FDT((fdt_property_cell(fdt, "#address-cells", 0x2)));
> > _FDT((fdt_property_cell(fdt, "#size-cells", 0x2)));
> >
> > - /* /chosen */
> > - _FDT((fdt_begin_node(fdt, "chosen")));
> > -
> > - /* Set Form1_affinity */
> > - _FDT((fdt_property(fdt, "ibm,architecture-vec-5", vec5,
> > sizeof(vec5))));
> > -
> > - _FDT((fdt_property_string(fdt, "bootargs", machine->kernel_cmdline)));
> > - _FDT((fdt_property(fdt, "linux,initrd-start",
> > - &start_prop, sizeof(start_prop))));
> > - _FDT((fdt_property(fdt, "linux,initrd-end",
> > - &end_prop, sizeof(end_prop))));
> > - if (spapr->kernel_size) {
> > - uint64_t kprop[2] = { cpu_to_be64(KERNEL_LOAD_ADDR),
> > - cpu_to_be64(spapr->kernel_size) };
> > -
> > - _FDT((fdt_property(fdt, "qemu,boot-kernel", &kprop,
> > sizeof(kprop))));
> > - if (spapr->kernel_le) {
> > - _FDT((fdt_property(fdt, "qemu,boot-kernel-le", NULL, 0)));
> > - }
> > - }
> > - if (boot_menu) {
> > - _FDT((fdt_property_cell(fdt, "qemu,boot-menu", boot_menu)));
> > - }
> > - _FDT((fdt_property_cell(fdt, "qemu,graphic-width", graphic_width)));
> > - _FDT((fdt_property_cell(fdt, "qemu,graphic-height", graphic_height)));
> > - _FDT((fdt_property_cell(fdt, "qemu,graphic-depth", graphic_depth)));
> > -
> > - _FDT((fdt_end_node(fdt)));
> > -
> > /* RTAS */
> > _FDT((fdt_begin_node(fdt, "rtas")));
> >
> > @@ -873,6 +840,68 @@ int spapr_h_cas_compose_response(sPAPRMachineState
> > *spapr,
> > return 0;
> > }
> >
> > +static void spapr_dt_chosen(sPAPRMachineState *spapr, void *fdt)
> > +{
> > + MachineState *machine = MACHINE(spapr);
> > + int chosen;
> > + const char *boot_device = machine->boot_order;
> > + char *stdout = spapr_vio_stdout_path(spapr->vio_bus);
>
> Ah, by the way, calling a variable "stdout" like the FILE* from stdio.h
> feels somewhat wrong ... could you maybe use another name here instead?
Ah.. a very good idea. Given the troubles I've seen with variables
called 'index' shadowing the standard library function, calling it
stdout is a terrible idea.
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature
- Re: [Qemu-ppc] [PATCH 13/13] spapr: Remove spapr_create_fdt_skel(), (continued)
- [Qemu-ppc] [PATCH 11/13] spapr: Move /hypervisor node construction to fdt_build_fdt(), David Gibson, 2016/10/20
- [Qemu-ppc] [PATCH 07/13] spapr: Move construction of /interrupt-controller fdt node, David Gibson, 2016/10/20
- [Qemu-ppc] [PATCH 12/13] spapr: Consolidate construction of /vdevice device tree node, David Gibson, 2016/10/20
- [Qemu-ppc] [PATCH 08/13] spapr: Consolidate construction of /chosen device tree node, David Gibson, 2016/10/20
- [Qemu-ppc] [PATCH 09/13] pseries: Consolidate construction of /rtas device tree node, David Gibson, 2016/10/20