[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot install Windows 10 (Win10_21H1_English_x64) with qemu 6.0.0

From: Pascal
Subject: Re: Cannot install Windows 10 (Win10_21H1_English_x64) with qemu 6.0.0
Date: Mon, 12 Jul 2021 10:34:43 +0200

my 21H1 is running with UEFI activated in the VM (-bios ...) : try on this side...

Le lun. 12 juil. 2021 à 10:27, Stefano Cappa <stefano.cappa.ks89@gmail.com> a écrit :
I'm trying to install Windows 10 64 bit (latest available official iso)

my environment:
- macbook pro 13 2020 (intel)
- macos BigSur (with all updates)
- qemu-system-x86_64 version 6.0.0
- os to install "Win10_21H1_English_x64.iso" from official Microsoft website
- virtio iso driver (tried with both virtio-win-0.1.185.iso and virtio-win-0.1.196.iso)

I start qemu with this command:

qemu-system-x86_64 \
-smp 4 \
-M q35 \
-m 4096 \
-vga std \
-display vnc=:0 \
-netdev user,id=n0 \
-device virtio-net-pci,netdev=n0 \
-device virtio-serial-pci \
-device virtserialport,chardev=qga0,name=org.qemu.guest_agent.0 \
-chardev socket,id=qga0,port=8125,host=,server,nowait \
-usb -device usb-tablet \
-qmp tcp:,server,nowait \
-k it \
-boot d \
-drive file=./filesystem.qcow2,if=virtio,format=qcow2,index=0,media=disk \
-drive file=./Win10_21H1_English_x64.iso,index=1,media=cdrom \
-drive file=./virtio-win-0.1.185.iso,index=2,media=cdrom

Everything seems ok, because I can install Windows 10, but when it reboots and it prepares to start it hangs in the "Just a moment..." screen. After many minutes it reboots showing the message that Windows failed to start and it shows the troubleshooting page.
I didn't find any way to install windows 10, at the moment.

I also tried removing all "virtio" stuff from the command and also without "-M q35".

Any suggestions?
Thank you.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]