[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AIX 7.2 install on QEMU on Windows unable to accept arrow keys

From: ??????
Subject: AIX 7.2 install on QEMU on Windows unable to accept arrow keys
Date: Wed, 24 Mar 2021 13:28:14 +0800

I am currently trying to create an AIX 7.2 image using QEMU on Windows following these steps: http://aix4admins.blogspot.com/2020/04/qemu-aix-on-x86-qemu-quick-emulator-is.html

I am now almost at the end -- with QEMU booting from the .img file instead of the ISO, but I am stuck at the install process where I have to accept the AIX Software License Agreement (before anyone asks, yes, this is a legal copy of AIX). I am unable to move the cursor to select the "Accept" option - it seems like it's not accepting the arrow keys. I am able to input other keys though, as previous steps required me to type in choices. For this screen I am also able to select the bottom options like help (Esc-1), refresh (Esc-2) etc.

enter image description here

I have tried the following:

  1. Run qemu from Windows prompt, with terminal set to xterm - doesn't work
  2. Run qemu from powershell, terminal set to xterm via registry, doesn't work
  3. Run qemu from Ubuntu/WSL2, terminal set to xterm, doesn't work (also tried vt100, doesn't work)
  4. I've tried adding the -k en-us parameter for keyboard to all iterations above, didn't work

I'm using this command:

../qemu/qemu-system-ppc64.exe -cpu POWER8 -machine pseries -m 2048 -serial stdio -drive file=aix-hdd.img,if=none,id=drive-virtio-disk0 -device virtio-scsi-pci,id=scsi -device scsi-hd,drive=drive-virtio-disk0 -cdrom aix_7200-04-01-1939_flash_112019.iso -prom-env "boot-command=boot disk:" -display vnc=:1 -k en-us

I've also tried using VNC to connect, but the install options don't appear in the VNC stream.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]