[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Restoring QEMU+KVM snapshot on QEMU-only instance

From: Georgios Tziantzioulis
Subject: Restoring QEMU+KVM snapshot on QEMU-only instance
Date: Wed, 17 Jun 2020 00:16:15 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0

Hi Everyone,

    I am trying to collect some custom execution traces and I am having some difficult with the snapshot/checkpoint infrastructure of QEMU.

Specifically, my goal is to use QEMU+KVM to bring up my system to an initial state and then take a snapshot of it (using savevm), following I want to restore the snapshot (using loadvm) on a QEMU-only instance  -- that is KVM is disabled/not-enabled -- to perform the trace collection.

So far I have not been successful on restoring a QEMU+KVM snapshot on a QEMU-only instance. After loading the snapshot I do not see any progress or response on the guest terminal (info status reports 'VM status: running').

I have tried using a number of -cpu model with no success.

I am using virtio and a qcow2 image.

The operating system of the guest is Ubuntu 18.04.

I am using a recent upstream version of qemu (commit: 175198ad91d8bac540159705873b4ffe4fb94eab; Fri Jun 5, 2020)

Has anyone tried something similar with success. Can someone point me to the right direction on how to solve this issue?

Thank you in advance.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]