[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] QEMU Snapshots on Sabrelite IMX.6 do not work

From: alsn
Subject: [Qemu-discuss] QEMU Snapshots on Sabrelite IMX.6 do not work
Date: Fri, 09 Aug 2019 08:49:50 +0200
User-agent: GWP-Draft

Hello,  I'm
trying to take   and
restore   a
snapshot  with
the whole system state of the  Sabrelite
IMX.6  board running on QEMU with  commands savevm/loadvm .    It seem s  that 
I am able to take a snapshot but loading the snapshot fails. For
comparison I checked out snapshots on 32bit ARM Virt with Debian as
well as on the Versatilepb board with a bare metal application and it
works fine.    The problem occurs only with that one particular
board. At
the moment I ran out of ideas what's the reason of the problem.  My
environment is:  Ubuntu
18.04  QEMU
3.0.1 ( I
see the  same
issue  in
QEMU  4.0.0  as well)     The
kernel and device tree used for the board was 5.1.14 version from
kernel.org The
file system was build from  imx_v6_v7_defconfig   config in
buildroot as and sd card image.  Problem:  Loading
snapshot stops  the  whole
machine and it's impossible to resume it.  Steps
to reproduce problem:  1.     
I converted the sdcard.img built from the buildroot to qcow2 using
command qemu-img convert -f raw -O qcow2 sdcard.img
sdcard.qcow2, sinc the raw doesn't support snapshots.  2.     
I start QEMU with a command    ./arm-softmmu/qemu-system-arm -m
512 -M sabrelite -kernel zImage -append "rootfstype=ext4
root=/dev/mmc rw rootwait" -rtc base=localtime,clock=vm
-dtb imx6dl-sabresd.dtb -drive
file=sdcard.qcow2,index -device
sd-card,drive=mycard -nographic -net nic -net user 3.     
I run a simple program which print characters to the console in the
background and add some files in user directory, to differ from
original image.  4.     
I switch to QEMU monitor, and type “savevm <name>”.    When
I type “info snapshots”, the snapshot is listed.    So I
assume it was saved correctly. 5.     
Then I switch back to Linux console from monitor, remove the added
files and stop the background printing process.  6.     
I switch back to monitor and I'm trying now to load the snapshot by
“loadvm <name>” command.    That’s
where the problem occurs. QEMU stops and I can't switch back from
monitor to Linux.    Typing “cont” doesn’t help.    It
seems like the simulation has freezed. CPU usage on my Laptop machine
equals 100% until I exit QEMU.  What’s
interesting when I exit the QEMU and then start it again the Linux
boots and after it reaches the command prompt I can see the files
which were removed after saving the snapshot. It
looks like loading the snapshots works for restoring disk space but
it fails for restoring the running processes.  I
thought that this may be a problem with not enough space on the sd
card to store the snapshot but after resizing from 63M to 500MB (in
buildroot) the problem remains the same.    I
will appreciate any comments or hints.  Regards,  …

reply via email to

[Prev in Thread] Current Thread [Next in Thread]