[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Black screens when connecting to Windows 10 vm's

From: Sebastian Arcus
Subject: Re: [Qemu-discuss] Black screens when connecting to Windows 10 vm's
Date: Wed, 21 Feb 2018 08:25:18 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.3.0

On 20/02/18 13:31, Narcis Garcia wrote:
Sebastian, you are talking about RDP connection. RDP server is Windows,
and Qemu/Libvirt have nothing to do.

It seems like asking here about FTP problems between an FTP client and
FTP server running in a VM.

If service fails, it's server issue.

Narcis, thank you for your reply. You are of course right in that the RDP server side of software runs entirely inside Windows, and it could very well be a Windows specific problem. However, virtualisation is a complex ecosystem, composed of many parts, all interacting together, sometimes in unexpected ways. Let's not forget that it is qemu/kvm which contributes to the network stack, the cpu management, the memory management and so on. Sometimes the cause of a problem is far removed from the actual software involved. I posted here by the off chance that someone else has hit this problem while using kvm/qemu.

El 19/02/18 a les 18:40, Sebastian Arcus ha escrit:
I've had this problem for almost a year now on one of my vm servers
running qemu/kvm with libvirt on Linux, With Windows 10 vms. Almost
every day, when users come to login remotely through RDP, they only get
a black screen and nothing else. I have to reboot the vm, and then
everything is fine.

1. CTRL+ALT+END in the rdp window doesn't bring up the Task Manager.
2. I can still ping the vm.
3. I can shut it down with virsh shutdown <vm_name>

I have tried upgrading qemu and libvirt - I am now on qemu 2.10.2 and
libvirt 4.0.0. I have another vm server with virtually the same config,
and never have this problem.

I've also tried changing the video from virtio to vga, and that didn't
make any difference.

The server runs 2 Windows 10 vm's, has 12GB of ram and an Intel Core
i5-4460 cpu.

I can't figure out how to narrow things down further - or even to figure
out if it is somehow caused by Windows, or by qemu/kvm. Any suggestions
are welcome.

Below is my graphics config from libvirt (I've enabled VNC temporarily
to be able to get back in when RDP stops working):

<graphics type='vnc' port='5900' autoport='no' listen=''
    <listen type='address' address=''/>
    <model type='vga' vram='32768' heads='1' primary='yes'/>
    <address type='pci' domain='0x0000' bus='0x00' slot='0x02'

reply via email to

[Prev in Thread] Current Thread [Next in Thread]