[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Black screens when connecting to Windows 10 vm's

From: Narcis Garcia
Subject: Re: [Qemu-discuss] Black screens when connecting to Windows 10 vm's
Date: Tue, 20 Feb 2018 14:31:54 +0100

Sebastian, you are talking about RDP connection. RDP server is Windows,
and Qemu/Libvirt have nothing to do.

It seems like asking here about FTP problems between an FTP client and
FTP server running in a VM.

If service fails, it's server issue.

El 19/02/18 a les 18:40, Sebastian Arcus ha escrit:
> I've had this problem for almost a year now on one of my vm servers
> running qemu/kvm with libvirt on Linux, With Windows 10 vms. Almost
> every day, when users come to login remotely through RDP, they only get
> a black screen and nothing else. I have to reboot the vm, and then
> everything is fine.
> 1. CTRL+ALT+END in the rdp window doesn't bring up the Task Manager.
> 2. I can still ping the vm.
> 3. I can shut it down with virsh shutdown <vm_name>
> I have tried upgrading qemu and libvirt - I am now on qemu 2.10.2 and
> libvirt 4.0.0. I have another vm server with virtually the same config,
> and never have this problem.
> I've also tried changing the video from virtio to vga, and that didn't
> make any difference.
> The server runs 2 Windows 10 vm's, has 12GB of ram and an Intel Core
> i5-4460 cpu.
> I can't figure out how to narrow things down further - or even to figure
> out if it is somehow caused by Windows, or by qemu/kvm. Any suggestions
> are welcome.
> Below is my graphics config from libvirt (I've enabled VNC temporarily
> to be able to get back in when RDP stops working):
> <graphics type='vnc' port='5900' autoport='no' listen=''
> keymap='en-gb'>
>    <listen type='address' address=''/>
> </graphics>
> <video>
>    <model type='vga' vram='32768' heads='1' primary='yes'/>
>    <address type='pci' domain='0x0000' bus='0x00' slot='0x02'
> function='0x0'/>
> </video>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]