[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Some not working devices in Windows 10 guest

From: Nerijus Baliūnas
Subject: Re: [Qemu-discuss] Some not working devices in Windows 10 guest
Date: Thu, 05 Jan 2017 14:05:39 +0200
User-agent: Roundcube Webmail/1.2.3

Could you please do not top post? It makes very difficult to reply

Yes, the solution has typos - hiinterrupt.inf and bidinterrupt.inf
should be hidinterrupt.inf.
I did exactly what solution says and that got rid of device with
exclamation mark.

2017-01-05 14:00, Xi Shen rašė:
Hi Nerijus,

i tried the trick, but it does not work.

First I don't have the key mentioned. I have


And under HKEY_LOCAL_MACHINE\SYSTEM\DriverDatabase\DeviceIds\ACPI\ACPI0010, I have

Which looks close, but not the same. I made a copy of those values and tried to delete them, but I
got an error.

Maybe it is not the same issue?


On Thu, Jan 5, 2017 at 8:34 AM Xi Shen <address@hidden> wrote:

"Looks like MS is trying to extend their acpi impl. to support more recent ACPI specs (which is good thing) but they made a typo and ACPI0011 "Generic Buttons Device" became ACPI0010."

A typo...seriously? Lol~

Thank you Nerijus.

On Thu, Jan 5, 2017 at 1:17 AM Nerijus Baliunas <address@hidden> wrote:

On Wed, 4 Jan 2017 17:24:44 +0100 Vincenzo Romano <address@hidden> wrote:

I have installed all the drivers shipped with that ISO, plus the qemu
agent, and spice guest tool. That "HID Button over Interrupt Driver" still has a exclamation mark on it. So far the guest system works well. I just
wonder what could it be.

I have exclamation mark too on Windows 10.

There's an answer about it. Read previous messages.

I found https://bugzilla.redhat.com/show_bug.cgi?id=1377155
It seems it is a Microsoft bug and there is info how to workaround it:

According to MS the solution is to remove the device:

1. Uninstall the existed driver package for this device, if can check delete button, please
check it too.

2. Download the PsTools from

3. Unzip PsTools, and locate the folder of PsTools, then input in CMD (Run as Administrator):

psexec -s -i regedit.exe

4. Delete subkey ACPI0010 under
HKLM\SYSTEM\DriverDataBase\DriverPackage\hiinterrupt.inf_x86_<some instance

And delete subkey "bidinterrupt.inf" under HKLM\SYSTEM\DriverDataBase\DeviceIds\ACPI\ACPI0010

5. Rescan device to see the effect.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]