[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] How to set the network card for qemu to use?

From: Miroslav Rovis
Subject: Re: [Qemu-discuss] How to set the network card for qemu to use?
Date: Thu, 13 Oct 2016 20:56:22 +0200
User-agent: Mutt/1.7.0 (2016-08-17)

Hi, Aleksei!

I like the conversation style instead of top posting (if you don't mind
;-) . Less typing, and much clearer the line of discussion.

On 161013-10:11+0300, Aleksei wrote:
> Hi,
> If you want VM to use host's physical NIC exclusively, then do a PCI 
> pass-through.
I had already figured that...

And I also figured that the bridging would bring me, just what you write:
> If you just want VM to be on the same network as one of the NIC's, then 
> do the bridging. Create a bridge on the host, make that NIC a slave, 
> specify that bridge in Qemu command line. See here for details: 
> https://wiki.archlinux.org/index.php/QEMU#Bridged_networking_using_qemu-bridge-helper
> and https://wiki.archlinux.org/index.php/Network_bridge
I had also visited, previously, these and many other pages about Qemu.

But my problem is that the way my network cards in my Gentoo machine,
which sometimes functions as router for local network, are configured,
and its how their naming "naturally" comes up consistently after every
boot, [the way my network cards in my Gentoo machine] is:
eth0 -- local network [when used]
eth1 -- local network [when used]
eth2 -- connection to broadband router

And my problem is, I can't firure out the way to get qemu to try and get
either the passthrough or the bridging slave, via any other than:
(which, of course, fails).

> /--Regards, Aleksei/

Thanks for offering your help!

So, basically I'm studying further... And will be thankful if anybody
has any pointers to where to look for the solution...

The below is, more or less, in the same line as what I restated today...

> > Either for pass-through (the default, the SLIRP, IIUC), or I had
> > previously tried to set a tap0 device to a host br0, but couldn't get
> > qemu to set the image it boots to use one of a few NIC cards.
> >
> > Concrete setup is three NIC cards:
> > eth0
> > eth1
> > eth2
> >
> > And the question is simple: what -netdev options (or is there some other
> > way?) do I use to get qemu to use eth2?

See this:
> > Because it invariably chooses eth0.
> >
> > I tried several images, such as Tails and Devuan. Always chooses: eth0.
That above is the crux of the matter.

where find this line:

(it is one line, just greater than 79 char, so broken)

I thought maybe the solution would be somewhere in those, if I set a tap device 
and enslave it to eth2 enslaved to bridge (the bridge I was previously able to 
create, and it worked, but only for eth2)  ... But how do I get a file 
decriptor of eth2 ?

Thanks if anybody gives more help on this!
Miroslav Rovis
Zagreb, Croatia

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]