[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] How to set the network card for qemu to use?

From: Miroslav Rovis
Subject: Re: [Qemu-discuss] How to set the network card for qemu to use?
Date: Fri, 14 Oct 2016 06:47:31 +0200
User-agent: Mutt/1.7.0 (2016-08-17)

On 161014-03:11+0200, Miroslav Rovis wrote:
> > > > Concrete setup is three NIC cards:
> > > > eth0
> > > > eth1
> > > > eth2
> > > >
> > > > And the question is simple: what -netdev options (or is there some other
> > > > way?) do I use to get qemu to use eth2?
And that proved, to me, impossible.
> I think I should try and maybe get the NIC that I connect to internet
> with to get the name eth0 instead of the above.
And I thought of adding this line to kernel command line in grub.cnf :
> netdev=21,,0x000000000001d000,,eth0
> (and report back if that was, by some odd chance, successful)

Here's the way I gone through, it has concluded, you'll see why I'm
posting it. Following is a text already previously written, all is
over by now here....

One unsuccessful attempt, similar to mine, that I found:

(notice it's a company, and nobody replied)

Also I found this old thread:

(which I, in the end, haven't read, there were other tries there... but
likely the result was similar or same to mine)

Similar solutions offered at:


full reqest uri (clean):

It's very much worth noticing that there are some fine explanations there,
but part of those explanations look very much to be obsolete stuff --
year 2011

where the suggestion reads:


( of course, changing it to:

netdev=irq=21,name=eth0 )

Maybe that should do.

So instead of what I first thought:
> netdev=21,,0x000000000001d000,,eth0

I think I should try:

In the end I tried all of the above, and nothing worked. But nothing
nothing nothing. The kernel behaved as if there wasn't that line at all
(other then printing it in the logs).

I said further above: You'll see why I'm posting it. And it's because
this is probably impossible to do, and the kernel-parameters.txt should
probably be revises, at least for some ethernet cards.

It is probably that I have to use a different card, one that is eth0 on
every boot if I want qemu with pass-through.

Curiosity still lives here. If there were any successes in getting those
parameters to work, or if there are more explanations, I'll be glad to

Miroslav Rovis
Zagreb, Croatia

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]